1 .TH MHSHOW %manext1% 2015-02-08 "%nmhversion%"
6 mhshow \- display nmh MIME messages
27 .RB [ \-concat " | " \-noconcat ]
28 .RB [ \-textonly " | " \-notextonly ]
29 .RB [ \-inlineonly " | " \-noinlineonly ]
30 .RB [ \-header " | " \-noheader ]
39 command displays contents of a MIME (multi-media) message, or collection
43 manipulates multi-media messages as specified in RFC 2045 to RFC 2049.
46 only supports encodings in message bodies, and does not support the
47 encoding of message headers as specified in RFC 2047.
51 will display only the text parts of a message that are not marked as
52 attachments. This behavior can be changed by the
57 In addition, by using the
62 switches, you may limit and reorder the set of parts to be displayed,
63 based on part number and/or content type.
68 switches will override the default settings of
75 switch controls whether
77 will print a message separator header before each message that it
78 displays. The header format can be controlled using
80 to specify a file containing
82 instructions. A copy of the built-in default headerform can be found
83 in %nmhetcdir%/mhshow.header, for reference.
84 In addition to the normal set of
86 instructions, a "%{folder}" escape provides a string representing
91 will concatenate all content under one pager. If you want each part to
92 be displayed separately, you can override the default behavior with
100 to use the specified file as the source message, rather than a message
101 from a folder. If you specify this file as \*(lq-\*(rq, then
103 will accept the source message on the standard input. Note that the
104 file, or input from standard input, should be a validly formatted message,
109 be in mail drop format (to convert a file in
110 mail drop format to a folder of
117 switch can be given (one or more times) to restrict the set of
118 subparts that will be displayed. (Obviously with no
120 switches, all parts will be considered.) If a
122 switch specifies a specific subpart (i.e., a "leaf" in the tree of
123 MIME parts), then that part will always be displayed. If a
125 switch references a multipart/alternative part, then (in
128 switch) only the default subpart of that multipart will be displayed.
130 A part specification consists of a series of numbers separated by dots.
131 For example, in a multipart content containing three parts, these
132 would be named as 1, 2, and 3, respectively. If part 2 was also a
133 multipart content containing two parts, these would be named as 2.1 and
134 2.2, respectively. Note that the
136 switch is effective only for messages containing a multipart content.
137 If a message has some other kind of content, or if the part is itself
138 another multipart content, the
140 switch will not prevent the content from being acted upon.
144 switch can also be used to restrict (or, when used in conjunction with
146 to further restrict) the display of parts according to content type.
149 switches part will only select the first match from a multipart/alternative,
150 even if there is more than one subpart that matches (one of) the given
157 switches alone will cause either switch to select the part(s) they match.
158 Using them together will select only the part(s) matched by both (sets of)
159 switches. In other words, the result is the intersection, and not the union,
160 of their separate match results.
162 A content specification consists of a content type and a subtype.
163 The initial list of \*(lqstandard\*(rq content types and subtypes can
164 be found in RFC 2046.
166 A list of commonly used contents is briefly reproduced here:
170 .ta \w'application 'u
174 multipart mixed, alternative, digest, parallel
175 message rfc822, partial, external-body
176 application octet-stream, postscript
183 A legal MIME message must contain a subtype specification.
185 To specify a content, regardless of its subtype, just use the
186 name of the content, e.g., \*(lqaudio\*(rq. To specify a specific
187 subtype, separate the two with a slash, e.g., \*(lqaudio/basic\*(rq.
188 Note that regardless of the values given to the
190 switch, a multipart content (of any subtype listed above) is always
191 acted upon. Further note that if the
193 switch is used, and it is desirable to act on a message/external-body
196 switch must be used twice: once for message/external-body and once
197 for the content externally referenced.
202 will select the "best" displayable subpart from multipart/alternative
205 switch can be used (one or more times, in order of ascending
206 preference) to let MH know which content types from a
207 multipart/alternative MIME part are preferred by the user, in order to
208 override the default selection for display. For example, mail is
209 often sent containing both plaintext and HTML-formatted versions of
210 the same content, and the HTML version is usually indicated to be the
211 "best" format for viewing. Using \*(lq-prefer text/plain\*(rq will
212 cause the plaintext version to be displayed if possible, but still
213 allow display of the HTML part if there is no plaintext subpart
214 available. Using \*(lq-prefer text/plain -prefer image/png\*(rq
215 would add a preference for PNG images, which might or might not
216 ever appear in the same multipart/alternative section with text/plain.
217 Implementation note: RFC 2046 requires that the subparts
218 of a multipart/alternative be ordered according to "faithfulness to
219 the original content", and MH by default selects the subpart ranked
220 most "faithful" by that ordering. The
222 switch reorders the alternative parts (only internally, never changing
223 the message file) to move the user's preferred part(s) to the "most
224 faithful" position. Thus, when viewed by
226 the ordering of multipart/alternative parts will appear to change when
227 invoked with or without various
229 switches. Since the last of multiple
233 on the command line will override any in a profile entry.
237 switch will cancel any previous
240 .SS "Unseen Sequence"
241 If the profile entry \*(lqUnseen\-Sequence\*(rq is present and
244 will remove each of the messages shown from each sequence named by
246 .SS "Showing the Contents"
247 The headers of each message are displayed with the
251 using the standard format file,
253 You may specify an alternative format file with the
256 switch. If the format file
258 is specified, then the display of the message headers is suppressed.
260 Next, the contents are extracted from the message and are stored in
261 a temporary file. Usually, the name of the temporary file is the
262 word \*(lqmhshow\*(rq followed by a string of characters. Occasionally,
263 the method used to display a content (described next), requires that
264 the file end in a specific suffix. For example, the
266 command (part of the StarOffice package) can be used to display
267 Microsoft Word content, but it uses the suffix to determine how to display
268 the file. If no suffix is present, the file is not correctly loaded.
269 Similarly, older versions of the
271 command append a \*(lq.ps\*(rq suffix to the filename if one was missing.
272 As a result, these cannot be used to read the default temporary file.
274 To get around this, your profile can contain lines of the form:
277 mhshow-suffix-<type>/<subtype>: <suffix>
283 mhshow-suffix-<type>: <suffix>
286 to specify a suffix which can be automatically added to the temporary
287 file created for a specific content type. For example, the following
288 lines might appear in your profile:
292 mhshow-suffix-text: .txt
293 mhshow-suffix-application/msword: .doc
294 mhshow-suffix-application/PostScript: .ps
298 to automatically append a suffix to the temporary files.
300 The matching with the content type identifier is case-insensitive, both in
301 mhshow-suffix-<type> and mhshow-show-<type> (below) profile entries.
303 The method used to display the different contents in the messages bodies
304 will be determined by a \*(lqdisplay string\*(rq. To find the display
307 will first search your profile for an entry of the form:
310 mhshow-show-<type>/<subtype>
315 will search for an entry of the form:
321 to determine the display string.
323 If a display string is found, any escapes (given below) will be expanded.
324 The result will be executed under \*(lq/bin/sh\*(rq, with the standard input
327 The display string may contain the following escapes:
332 %a Insert parameters from Content-Type field
333 %{parameter} Insert the parameter value from the Content-Type field
334 %f Insert filename containing content
335 %F %f, and stdin is terminal not content
336 %l display listing prior to displaying content
337 %s Insert content subtype
338 %d Insert content description
339 %% Insert the character %
344 will execute at most one display string at any given time, and wait
345 for the current display string to finish execution before executing
346 the next display string.
348 The {parameter} escape is typically used in a command line argument
349 that should only be present if it has a non-null value. It is highly
350 recommended that the entire escape be wrapped in double quotes.
351 Shell parameter expansion can construct the argument only when it is
356 mhshow-show-text/html: charset="%{charset}";
357 w3m ${charset:+-I $charset} -T text/html %F
361 That example also shows the use of indentation to signify continuation:
362 the two text lines combine to form a single entry. Note that when
363 dealing with text that has been converted internally by
365 the \*(lqcharset\*(rq parameter will reflect the target character set
366 of the text, rather than the original character set in the message.
368 Note that if the content being displayed is multipart, but not one of
369 the subtypes listed above, then the f- and F-escapes expand to multiple
370 filenames, one for each subordinate content. Furthermore, stdin is not
371 redirected from the terminal to the content.
373 If a display string is not found,
375 behaves as if these profile entries were supplied and supported:
379 mhshow-show-text/plain: %lmoreproc %F
380 mhshow-show-message/rfc822: %lshow -file %F
384 Note that \*(lqmoreproc\*(rq is not supported in user profile display
387 If a subtype of type text doesn't have a profile entry, it will be
388 treated as text/plain.
391 has default methods for handling multipart messages of subtype
392 mixed, alternative, parallel, and digest. Any unknown subtype of type
393 multipart (without a profile entry), will be treated as multipart/mixed.
395 If none of these apply, then
397 will check to see if the message has an application/octet-stream content
398 with parameter \*(lqtype=tar\*(rq.
401 will use an appropriate command. If not,
405 Example entries might be:
409 mhshow-show-audio/basic: raw2audio 2>/dev/null | play
410 mhshow-show-image: xv %f
411 mhshow-show-application/PostScript: lpr -Pps
415 If an f- or F-escape is not quoted with single quotes, its expansion
416 will be wrapped with single quotes.
420 will process each message serially\0--\0it won't start showing the next
421 message until all the commands executed to display the current message
423 .SS "Showing Alternate Character Sets"
428 then all text/plain parts of the message(s) will be displayed using
429 the character set of the current locale. See
431 for how to determine whether your
433 installation includes
435 support. To convert text parts other than text/plain, or if
439 an external program can be used, as described next.
441 Because a content of type text might be in a non-ASCII character
444 encounters a \*(lqcharset\*(rq parameter for this content, it checks
445 if your terminal can display this character set natively.
447 checks this by examining the current character set defined by the
449 environment variables. If the value of the locale character set is equal
450 to the value of the charset parameter, then
453 display this content without any additional setup. If the locale is not
456 will assume a value of \*(lqUS-ASCII\*(rq.
457 If the character set cannot be displayed natively, then
459 will look for an entry of the form:
462 mhshow-charset-<charset>
465 which should contain a command creating an environment to render
466 the character set. This command string should containing a single
467 \*(lq%s\*(rq, which will be filled-in with the command to display the
470 Example entries might be:
473 mhshow-charset-iso-8859-1: xterm -fn '-*-*-medium-r-normal-*-*-120-*-*-c-*-iso8859-*' -e %s
479 mhshow-charset-iso-8859-1: '%s'
482 The first example tells
486 and load the appropriate character set for that message content.
490 that your pager (or other program handling that content type) can
491 handle that character set, and that no special processing is
494 Note that many pagers strip off the high-order bit, or have problems
495 displaying text with the high-order bit set. However, the pager
497 has support for single-octet character sets. For example, messages
498 encoded in the ISO-8859-1 character set can be viewed using
500 with these environment variable settings:
510 The first setting tells
512 to use the ISO-8859-1 definition to determine whether a character is
513 \*(lqnormal\*(rq, \*(lqcontrol\*(lq, or \*(lqbinary\*(rq.
514 The second setting tells
516 not to warn you if it encounters a file that has non-ASCII characters.
521 and it will get called automatically. (To handle other single-octet
522 character sets, look at the
524 manual entry for information about the LESSCHARDEF environment variable.)
525 .SS "Messages of Type message/partial"
527 cannot directly display messages of type partial.
528 You must first reassemble them into a normal message using
533 .SS "External Access"
534 For contents of type message/external-body,
536 supports these access-types:
550 For the \*(lqanon-ftp\*(rq and \*(lqftp\*(rq access types,
552 will look for the \*(lqnmh-access-ftp\*(rq profile entry, e.g.,
555 nmh-access-ftp: myftp.sh
558 to determine the pathname of a program to perform the FTP retrieval.
560 This program is invoked with these arguments:
564 domain name of FTP-site
570 \*(lqascii\*(rq or \*(lqbinary\*(rq
574 The program should terminate with an exit status of zero if the
575 retrieval is successful, and a non-zero exit status otherwise.
577 For the \*(lqurl\*(rq access-type,
579 will look for the \*(lqnmh-access-url\*(rq profile entry. See
582 .SS "User Environment"
583 Because the display environment in which
585 operates may vary for different machines,
587 will look for the environment variable MHSHOW. If present, this specifies
588 the name of an additional user profile which should be read.
589 Hence, when a user logs in on a particular display device, this environment
590 variable should be set to refer to a file containing definitions useful
591 for the given display device.
592 Normally, only entries that deal with the methods to display different
593 content type and subtypes
597 mhshow-show-<type>/<subtype>
602 need be present in this additional profile. Finally,
604 will attempt to consult
607 %nmhetcdir%/mhn.defaults
610 which is created automatically during
614 See "Profile Lookup" in
616 for the profile search order, and for how duplicate entries are treated.
617 .SS Content-Type Marker
619 will display a marker containing information about the part being displayed
620 next. The default marker can be changed using the
622 switch to specify a file containing
624 instructions to use when displaying the content marker. A copy of the
625 default markform can be found in %nmhetcdir%/mhshow.marker, for
626 reference. In addition to the normal set of
628 instructions, the following
630 escapes are supported:
634 .ta \w'cdispo-<PARAM> 'u +\w'Returns 'u
635 .I "Escape Returns Description"
636 part string MIME part number
637 content\-type string MIME Content\-Type of part
638 description string Content\-Description header
639 disposition string Content disposition (attachment or inline)
640 ctype-<PARAM> string Value of <PARAM> from Content\-Type header
641 cdispo-<PARAM> string Value of <PARAM> from
642 Content\-Disposition header
643 %(size) integer The size of the decoded part, in bytes
644 %(unseen) boolean Returns true for suppressed parts
646 In this context, the %(unseen) function indicates whether
648 has decided to not display a particular part due to the
654 All MIME parameters and the \*(lqContent-Description\*(rq header will have
655 RFC 2231 decoding applied and be converted to the local character set.
658 looks for all format files and mhn.defaults in multiple locations:
659 absolute pathnames are accessed directly, tilde expansion is done on
660 usernames, and files are searched for in the user's
662 directory, as specified in their profile. If not found there, the directory
663 .RI \*(lq %nmhetcdir% \*(rq
668 .ta \w'%nmhetcdir%/ExtraBigFileName 'u
669 ^$HOME/.mh_profile~^The user profile
670 ^$MHSHOW~^Additional profile entries
671 ^%nmhetcdir%/mhn.defaults~^System default MIME profile entries
672 ^%nmhetcdir%/mhl.headers~^The headers template
673 ^%nmhetcdir%/mhshow.marker~^Example content marker
674 ^%nmhetcdir%/mhshow.header~^Example message separator header
676 .SH "PROFILE COMPONENTS"
680 .ta \w'ExtraBigProfileName 'u
681 ^Path:~^To determine the user's nmh directory
682 ^Current\-Folder:~^To find the default current folder
683 ^Unseen\-Sequence:~^To name sequences denoting unseen messages
684 ^mhlproc:~^Default program to display message headers
685 ^nmh-access-ftp:~^Program to retrieve contents via FTP
686 ^nmh-access-url:~^Program to retrieve contents via HTTP
687 ^mhshow-charset-<charset>~^Template for environment to render character sets
688 ^mhshow-show-<type>*~^Template for displaying contents
689 ^moreproc:~^Default program to display text/plain content
701 .RB ` +folder "' defaults to the current folder"
702 .RB ` msgs "' defaults to cur"
707 .RB ` \-form\ mhl.headers '
710 If a folder is given, it will become the current folder. The last
711 message selected will become the current message.