1 .TH MHBUILD %manext1% "March 21, 2013" "%nmhversion%"
6 mhbuild \- translate MIME composition draft
12 .RB [ \-auto " | " \-noauto ]
13 .RB [ \-list " | " \-nolist ]
14 .RB [ \-realsize " | " \-norealsize ]
15 .RB [ \-headers " | " \-noheaders ]
16 .RB [ \-directives " | " \-nodirectives ]
17 .RB [ \-rfc934mode " | " \-norfc934mode ]
18 .RB [ \-contentid " | " \-nocontentid ]
19 .RB [ \-verbose " | " \-noverbose ]
20 .RB [ \-check " | " \-nocheck ]
21 .RB [ \-headerencoding
22 .IR encoding\-algorithm
23 .RB " | " \-autoheaderencoding ]
30 command will translate a MIME composition draft into
34 creates multi-media messages as specified in RFC 2045
35 to RFC 2049. This includes the encoding of message headers as specified
38 If you specify the name of the composition file as \*(lq-\*(rq,
41 will accept the composition draft on the standard
42 input. If the translation of this input is successful,
44 will output the new MIME message to the standard output. This argument
45 must be the last argument on the command line.
47 Otherwise if the file argument to
49 is the name of a valid
50 composition file, and the translation is successful,
52 will replace the original file with the new MIME message. It will rename
53 the original file to start with the \*(lq,\*(rq character and end with the
54 string \*(lq.orig\*(rq, e.g., if you are editing the file \*(lqdraft\*(rq,
55 it will be renamed to \*(lq,draft.orig\*(rq. This allows you to easily
59 .SS "Listing the Contents"
64 to list the table of contents associated with the MIME message that is created.
69 that a one-line banner should be displayed above the listing. The
73 to evaluate the \*(lqnative\*(rq
74 (decoded) format of each content prior to listing. This provides an
75 accurate count at the expense of a small delay. If the
78 is present, then the listing will show any \*(lqextra\*(rq information
79 that is present in the message, such as comments in the
80 \*(lqContent-Type\*(rq header.
81 .SS "Translating the Composition File"
83 is essentially a filter to aid in the composition of MIME
88 \*(lqcomposition file\*(rq
89 into a valid MIME message. A
91 \*(lqcomposition file\*(rq
92 is just a file containing plain text that is interspersed
95 directives. When this file is processed
98 the various directives will be expanded to the
99 appropriate content, and will be encoded according to the MIME standards.
100 The resulting MIME message can then be sent by electronic mail.
102 The formal syntax for a
104 composition file is defined at the
105 end of this document, but the ideas behind this format are not complex.
106 Basically, the body contains one or more contents. A content consists of
107 either a directive, indicated with a \*(lq#\*(rq as the first character
108 of a line; or, plaintext (one or more lines of text). The continuation
109 character, \*(lq\\\*(lq, may be used to enter a single directive on more
115 /home/foobar/junk/picture.png
119 There are five kinds of directives: \*(lqtype\*(rq directives, which
120 name the type and subtype of the content; \*(lqexternal-type\*(rq
121 directives, which also name the type and subtype of the content; the
122 \*(lqmessage\*(rq directive (#forw), which is used to forward one or
123 more messages; the \*(lqbegin\*(rq directive (#begin), which is
124 used to create a multipart content; and the \*(lqon/off/pop\*(rq
125 directives (#on, #off, #pop) which control whether any other
126 directives are honored at all.
130 switch allows control over whether mhbuild will honor any of the
131 \*(lq#\*(rq-directives. This can also be affected with the #on or
132 #off directives, and #pop, which restores the state of processing to
133 that preceding the most recent #on or #off. (The #on, #off, and #pop
134 directives are always honored, of course.) This allows inclusion of
135 plain text which looks like mhbuild directives, without causing
142 printf("Hello, World!);
147 Currently the stack depth for the #on/off/pop directives is 32.
149 The \*(lqtype\*(rq directive is used to directly specify the type and
150 subtype of a content. You may only specify discrete types in this manner
151 (can't specify the types multipart or message with this directive).
152 You may optionally specify the name of a file containing the contents
153 in \*(lqnative\*(rq (decoded) format. If this filename starts with the
154 \*(lq|\*(rq character, then it represents a command to execute whose
155 output is captured accordingly.
160 #audio/basic |raw2audio -F < /usr/lib/sound/giggle.au
164 If a filename is not given,
166 will look for information in the
167 user's profile to determine how the different contents should be composed.
168 This is accomplished by consulting a composition string, and executing
171 with the standard output set to the content.
176 will echo any commands that are used to create contents in this way.
178 The composition string may contain the following escapes:
183 %a Insert parameters from directive
184 %f Insert filename containing content
185 %F %f, and stdout is not re-directed
186 %s Insert content subtype
187 %% Insert character %
193 will look for an entry of the form:
196 mhbuild-compose-<type>/<subtype>
199 to determine the command to use to compose the content. If this isn't
202 will look for an entry of the form:
205 mhbuild-compose-<type>
208 to determine the composition command. If this isn't found,
212 An example entry might be:
215 mhbuild-compose-audio/basic: record | raw2audio -F
218 Because commands like these will vary, depending on the display
219 environment used for login, composition strings for different
220 contents should probably be put in the file specified by the
222 environment variable, instead of directly in your
225 The \*(lqexternal-type\*(rq directives are used to provide a MIME
226 reference to a content, rather than enclosing the contents itself
227 (for instance, by specifying an ftp site). Hence, instead of
228 providing a filename as with the type directives, external-parameters
229 are supplied. These look like regular parameters, so they must be
230 separated accordingly. For example,
234 #@application/octet-stream; \\
236 conversions=compress \\
237 [this is the nmh distribution] \\
238 {attachment; filename="nmh.tar.gz"} \\
239 name="nmh.tar.gz"; \\
240 directory="/pub/nmh"; \\
241 site="ftp.math.gatech.edu"; \\
242 access-type=anon-ftp; \\
247 You must give a description string to separate the content parameters
248 from the external-parameters (although this string may be empty).
249 This description string is specified by enclosing it within
250 \*(lq[]\*(rq. A disposition string, to appear in a
251 \*(lqContent-Disposition\*(rq header, may appear in the optional
254 These parameters are of the form:
258 .ta \w'access-type= 'u
259 access-type= usually \fIanon-ftp\fR, \fImail-server\fR, or \fIurl\fR
261 permission= read-only or read-write
263 directory= directoryname (optional)
264 mode= usually \fIascii\fR or \fIimage\fR (optional)
265 size= number of octets
267 subject= subject to send
268 body= command to send for retrieval
273 A mimimum \*(lqexternal\-type\*(rq directive for the
280 #@application/octet-stream [] access-type=url; \\
281 url="http://download.savannah.gnu.org/releases/nmh/nmh-1.5.tar.gz"
285 Any long URLs will be wrapped according to RFC 2017 rules.
287 The \*(lqmessage\*(rq directive (#forw) is used to specify a message or
288 group of messages to include. You may optionally specify the name of
289 the folder and which messages are to be forwarded. If a folder is not
290 given, it defaults to the current folder. Similarly, if a message is not
291 given, it defaults to the current message. Hence, the message directive
294 command, except that the former uses
295 the MIME rules for encapsulation rather than those specified in RFC 934.
300 #forw +inbox 42 43 99
304 If you include a single message, it will be included directly as a content
305 of type \*(lqmessage/rfc822\*(rq. If you include more than one message,
308 will add a content of type \*(lqmultipart/digest\*(rq
309 and include each message as a subpart of this content.
311 If you are using this directive to include more than one message, you
314 switch. This switch will indicate that
316 should attempt to utilize the MIME encapsulation rules
317 in such a way that the \*(lqmultipart/digest\*(rq that is created
318 is (mostly) compatible with the encapsulation specified in RFC 934.
319 If given, then RFC 934 compliant user-agents should be able to burst the
320 message on reception\0--\0providing that the messages being encapsulated
321 do not contain encapsulated messages themselves. The drawback of this
322 approach is that the encapsulations are generated by placing an extra
323 newline at the end of the body of each message.
325 The \*(lqbegin\*(rq directive is used to create a multipart content.
326 When using the \*(lqbegin\*(rq directive, you must specify at least one
327 content between the begin and end pairs.
332 This will be a multipart with only one part.
337 If you use multiple directives in a composition draft,
340 automatically encapsulate them inside a multipart content. Therefore the
341 \*(lqbegin\*(rq directive is only necessary if you wish to use nested
342 multiparts, or create a multipart message containing only one part.
344 For all of these directives, the user may include a brief description
345 of the content between the \*(lq[\*(rq character and the \*(lq]\*(rq
346 character. This description will be copied into the
347 \*(lqContent-Description\*(rq header when the directive is processed.
351 #forw [important mail from Bob] +bob 1 2 3 4 5
355 Similarly, a disposition string may optionally be provided between
356 \*(lq{\*(rq and \*(lq}\*(rq characters; it will be copied into the
357 \*(lqContent-Disposition\*(rq header when the directive is processed.
358 If a disposition string is provided that does not contain a filename
359 parameter, and a filename is provided in the directive, it will be
360 added to the \*(lqContent-Disposition\*(rq header. For example, the
365 #text/plain; charset=iso-8859-1 <>{attachment} /tmp/summary.txt
369 creates these message part headers:
373 Content-Type: text/plain; charset="iso-8859-1"
374 Content-Disposition: attachment; filename="summary.txt"
380 will generate a unique \*(lqContent-ID:\*(rq for each directive,
381 corresponding to each message part; however, the user may override
382 this by defining the ID using the \*(lq<\*(rq and \*(lq>\*(rq
385 switch suppresses creation of all \*(lqContent-ID:\*(rq headers,
386 even in the top level of the message.
388 In addition to the various directives, plaintext can be present.
389 Plaintext is gathered, until a directive is found or the draft is
390 exhausted, and this is made to form a text content. If the plaintext
391 must contain a \*(lq#\*(rq at the beginning of a line, simply double it,
395 ##when sent, this line will start with only one #
398 If you want to end the plaintext prior to a directive, e.g., to have two
399 plaintext contents adjacent, simply insert a line containing a single
400 \*(lq#\*(rq character, e.g.,
404 this is the first content
406 and this is the second
410 Finally, if the plaintext starts with a line of the form:
413 Content-Description: text
416 then this will be used to describe the plaintext content.
417 You MUST follow this line with a blank line before starting
420 By default, plaintext is captured as a text/plain content. You can
421 override this by starting the plaintext with \*(lq#<\*(rq followed by
422 a content-type specification. For example, e.g.,
427 this content will be tagged as text/enriched
429 and this content will be tagged as text/plain
431 #<application/x-patch [this is a patch]
432 and this content will be tagged as application/x-patch
436 Note that if you use the \*(lq#<\*(rq plaintext-form, then the
437 content-description must be on the same line which identifies the content
438 type of the plaintext.
440 When composing a text content, you may indicate the relevant character
441 set by adding the \*(lqcharset\*(rq parameter to the directive.
444 #<text/plain; charset=iso-8859-5
447 If a text content contains any 8\-bit characters (characters with the
448 high bit set) and the character set is not specified as above, then
450 will assume the character set is of the type given by the
451 environment variable MM_CHARSET. If this environment variable is not
452 set, then the character set will be labeled as \*(lqx-unknown\*(rq.
454 If a text content contains only 7\-bit characters and the character set
455 is not specified as above, then the character set will be labeled as
460 switch will indicate which algorithm to use when encoding any message headers
461 that contain 8\-bit characters. The valid arguments are
463 for based\-64 encoding and
465 for quoted\-printable encoding. The
466 .B \-autoheaderencoding
469 to automatically pick the algorithm that results in a shorter encoded string.
471 Putting this all together,
472 here is an example of a more complicated message draft. The
473 following draft will expand into a multipart/mixed message
474 containing five parts:
478 To: nobody@nowhere.org
480 Subject: Look and listen to me!
482 The first part will be text/plain
484 The second part will be text/enriched
486 This third part will be text/plain
487 #audio/basic [silly giggle] \\
488 |raw2audio -F < /usr/lib/sounds/giggle.au
489 #image/gif [photo of foobar] \\
490 /home/foobar/lib/picture.gif
493 .SS "Integrity Check"
498 switch, then it will also associate an integrity check with each
499 \*(lqleaf\*(rq content. This will add a Content-MD5 header field to
500 the content, along with the md5 sum of the unencoded contents, per RFC
501 1864. This may be used by the receiver of the message to verify that
502 the contents of the message were not changed in transport.
503 .SS "Transfer Encodings"
506 constructs the new MIME message by parsing directives,
507 including files, etc., it scans the contents of the message to determine
508 which transfer encoding to use. It will check for 8bit data, long lines,
509 spaces at the end of lines, and clashes with multipart boundaries. It will
510 then choose a transfer encoding appropriate for each content type.
512 If an integrity check is being associated with each content by using
517 will encode each content with
518 a transfer encoding, even it the content contains only 7\-bit data. This
519 is to increase the likelihood that the content is not changed while in
521 .SS "Invoking mhbuild"
527 command will expect the body of the draft to be formatted as an
529 composition file. Once you have composed this input file
530 using a command such as
537 at the \*(lqWhat now\*(rq prompt with
543 prior to sending the draft. This will cause
547 to translate the composition file into MIME format.
549 Normally it is an error to invoke
551 on file that already in MIME format. The
555 to exit without error if the input file already has valid MIME headers.
557 It is also possible to have the
561 automatically when a message is sent. To do this, you must add the line
571 Finally, you should consider adding this line to your profile:
577 This way, if you decide to
587 will work as you expect.
588 .SS "User Environment"
589 Because the environment in which
591 operates may vary for a
594 will look for the environment variable
596 If present, this specifies the name of an additional user profile which
597 should be read. Hence, when a user logs in on a particular machine,
598 this environment variable should be set to refer to a file containing
599 definitions useful for that machine.
603 will attempt to consult a global
608 %etcdir%/mhn.defaults
612 .SS "Syntax of Composition Files"
613 The following is the formal syntax of a
615 \*(lqcomposition file\*(rq.
619 body ::= 1*(content | EOL)
621 content ::= directive | plaintext
623 directive ::= "#" type "/" subtype
624 0*(";" attribute "=" value)
627 [ "[" description "]" ]
628 [ "{" disposition "}" ]
632 | "#@" type "/" subtype
633 0*(";" attribute "=" value)
636 [ "[" description "]" ]
637 [ "{" disposition "}" ]
643 [ "[" description "]" ]
644 [ "{" disposition "}" ]
645 [ "+"folder ] [ 0*msg ]
650 [ "[" description "]" ]
651 [ "{" disposition "}" ]
659 plaintext ::= [ "Content-Description:"
660 description EOL EOL ]
664 | "#<" type "/" subtype
665 0*(";" attribute "=" value)
667 [ "[" description "]" ]
668 [ "{" disposition "}" ]
673 line ::= "##" text EOL
674 -- interpreted as "#"text EOL
680 looks for additional user profile files and mhn.defaults in multiple
681 locations: absolute pathnames are accessed directly, tilde expansion
682 is done on usernames, and files are searched for in the user's
684 directory as specified in their profile. If not found there, the directory
685 .RI \*(lq %etcdir% \*(rq
690 .ta \w'%etcdir%/ExtraBigFileName 'u
691 ^$HOME/\&.mh\(ruprofile~^The user profile
692 ^$MHBUILD~^Additional profile entries
693 ^%etcdir%/mhn.defaults~^System default MIME profile entries
695 .SH "PROFILE COMPONENTS"
699 .ta \w'ExtraBigProfileName 'u
700 ^Path:~^To determine the user's nmh directory
701 ^Current\-Folder:~^To find the default current folder
702 ^mhbuild-compose-<type>*~^Template for composing contents
709 .I "Proposed Standard for Message Encapsulation"
712 .I "The Content-MD5 Header Field"
715 .I "Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies"
718 .I "Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types"
721 .I "Multipurpose Internet Mail Extensions (MIME) Part Three: Message Header Extensions for Non-ASCII Text"
724 .I "Multipurpose Internet Mail Extensions (MIME) Part Four: Registration Procedures"
727 .I "Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and Examples"
729 .I "Definition of the URL MIME External-Body Access-Type"
735 .RB ` \-norfc934mode '
739 .RB ` \-autoheaderencoding '