]> diplodocus.org Git - nmh/blob - man/mhbuild.man
4a0e87305422e9dda4cf70d24938cab48325c73b
[nmh] / man / mhbuild.man
1 .TH MHBUILD %manext1% "March 13, 2014" "%nmhversion%"
2 .\"
3 .\" %nmhwarning%
4 .\"
5 .SH NAME
6 mhbuild \- translate MIME composition draft
7 .SH SYNOPSIS
8 .na
9 .HP 5
10 .B mhbuild
11 .I file
12 .RB [ \-auto " | " \-noauto ]
13 .RB [ \-list " | " \-nolist ]
14 .RB [ \-realsize " | " \-norealsize ]
15 .RB [ \-headers " | " \-noheaders ]
16 .RB [ \-directives " | " \-nodirectives ]
17 .RB [ \-rfc934mode " | " \-norfc934mode ]
18 .RB [ \-contentid " | " \-nocontentid ]
19 .RB [ \-verbose " | " \-noverbose ]
20 .RB [ \-disposition " | " \-nodisposition ]
21 .RB [ \-check " | " \-nocheck ]
22 .RB [ \-headerencoding
23 .IR encoding\-algorithm
24 .RB " | " \-autoheaderencoding ]
25 .RB [ \-maxunencoded
26 .IR line\-length ]
27 .RB [ \-dist ]
28 .RB [ \-version ]
29 .RB [ \-help ]
30 .ad
31 .SH DESCRIPTION
32 The
33 .B mhbuild
34 command will translate a MIME composition draft into
35 a valid MIME message.
36 .PP
37 .B mhbuild
38 creates multi-media messages as specified in RFC 2045
39 to RFC 2049. This includes the encoding of message headers as specified
40 by RFC 2047, and the encoding of MIME parameters as specified in RFC 2231.
41 .PP
42 If you specify the name of the composition file as \*(lq-\*(rq,
43 then
44 .B mhbuild
45 will accept the composition draft on the standard
46 input. If the translation of this input is successful,
47 .B mhbuild
48 will output the new MIME message to the standard output. This argument
49 must be the last argument on the command line.
50 .PP
51 Otherwise if the file argument to
52 .B mhbuild
53 is the name of a valid
54 composition file, and the translation is successful,
55 .B mhbuild
56 will replace the original file with the new MIME message. It will rename
57 the original file to start with the \*(lq,\*(rq character and end with the
58 string \*(lq.orig\*(rq, e.g., if you are editing the file \*(lqdraft\*(rq,
59 it will be renamed to \*(lq,draft.orig\*(rq. This allows you to easily
60 recover the
61 .B mhbuild
62 input file.
63 .SS "Listing the Contents"
64 The
65 .B \-list
66 switch tells
67 .B mhbuild
68 to list the table of contents associated with the MIME message that is created.
69 .PP
70 The
71 .B \-headers
72 switch indicates
73 that a one-line banner should be displayed above the listing. The
74 .B \-realsize
75 switch tells
76 .B mhbuild
77 to evaluate the \*(lqnative\*(rq
78 (decoded) format of each content prior to listing. This provides an
79 accurate count at the expense of a small delay. If the
80 .B \-verbose
81 switch
82 is present, then the listing will show any \*(lqextra\*(rq information
83 that is present in the message, such as comments in the
84 \*(lqContent-Type\*(rq header.
85 .PP
86 If the
87 .B \-disposition
88 switch is present, then the listing will show any relevant information from
89 the \*(lqContent-Disposition\*(rq header.
90 .SS "Simplified Attachment Interface"
91 For users who wish to simply attach files to text content,
92 .B mhbuild
93 will scan the composition file for \*(lqAttach\*(rq headers. An
94 \*(lqAttach\*(rq header contains a filename that will be appended to the
95 message using normal MIME encapsulation rules. One filename is allowed
96 per \*(lqAttach\*(rq header, but multiple \*(lqAttach\*(rq headers are
97 allowed ber composition file.
98 .PP
99 These files will be appended after any other MIME content, including any
100 content specified by
101 .B mhbuild
102 directives (see below). See
103 .IR send (1)
104 for more details.
105 .SS "Translating the Composition File"
106 .B mhbuild
107 is essentially a filter to aid in the composition of MIME
108 messages.
109 .B mhbuild
110 will convert an
111 .B mhbuild
112 \*(lqcomposition file\*(rq
113 into a valid MIME message. A
114 .B mhbuild
115 \*(lqcomposition file\*(rq
116 is just a file containing plain text that is interspersed
117 with various
118 .B mhbuild
119 directives. When this file is processed
120 by
121 .BR mhbuild ,
122 the various directives will be expanded to the
123 appropriate content, and will be encoded according to the MIME standards.
124 The resulting MIME message can then be sent by electronic mail.
125 .PP
126 The formal syntax for a
127 .B mhbuild
128 composition file is defined at the
129 end of this document, but the ideas behind this format are not complex.
130 Basically, the body contains one or more contents. A content consists of
131 either a directive, indicated with a \*(lq#\*(rq as the first character
132 of a line; or, plaintext (one or more lines of text). The continuation
133 character, \*(lq\\\*(lq, may be used to enter a single directive on more
134 than one line, e.g.,
135 .PP
136 .RS 5
137 .nf
138 #image/png \\
139 /home/foobar/junk/picture.png
140 .fi
141 .RE
142 .PP
143 There are five kinds of directives: \*(lqtype\*(rq directives, which
144 name the type and subtype of the content; \*(lqexternal-type\*(rq
145 directives, which also name the type and subtype of the content; the
146 \*(lqmessage\*(rq directive (#forw), which is used to forward one or
147 more messages; the \*(lqbegin\*(rq directive (#begin), which is
148 used to create a multipart content; and the \*(lqon/off/pop\*(rq
149 directives (#on, #off, #pop) which control whether any other
150 directives are honored at all.
151 .PP
152 The
153 .B \-directives
154 switch allows control over whether mhbuild will honor any of the
155 \*(lq#\*(rq-directives. This can also be affected with the #on or
156 #off directives, and #pop, which restores the state of processing to
157 that preceding the most recent #on or #off. (The #on, #off, and #pop
158 directives are always honored, of course.) This allows inclusion of
159 plain text which looks like mhbuild directives, without causing
160 errors:
161 .PP
162 .RS 5
163 .nf
164 #off
165 #include <stdio.h>
166 printf("Hello, World!);
167 #pop
168 .fi
169 .RE
170 .PP
171 Currently the stack depth for the #on/off/pop directives is 32.
172 .PP
173 The \*(lqtype\*(rq directive is used to directly specify the type and
174 subtype of a content. You may only specify discrete types in this manner
175 (can't specify the types multipart or message with this directive).
176 You may optionally specify the name of a file containing the contents
177 in \*(lqnative\*(rq (decoded) format. If this filename starts with the
178 \*(lq|\*(rq character, then it represents a command to execute whose
179 output is captured accordingly.
180 For example,
181 .PP
182 .RS 5
183 .nf
184 #audio/basic |raw2audio -F < /usr/lib/sound/giggle.au
185 .fi
186 .RE
187 .PP
188 If a filename is not given,
189 .B mhbuild
190 will look for information in the
191 user's profile to determine how the different contents should be composed.
192 This is accomplished by consulting a composition string, and executing
193 it under
194 .BR /bin/sh ,
195 with the standard output set to the content.
196 If the
197 .B \-verbose
198 switch is given,
199 .B mhbuild
200 will echo any commands that are used to create contents in this way.
201 .PP
202 The composition string may contain the following escapes:
203 .PP
204 .RS 5
205 .nf
206 .ta \w'%P 'u
207 %a Insert parameters from directive
208 %f Insert filename containing content
209 %F %f, and stdout is not re-directed
210 %s Insert content subtype
211 %% Insert character %
212 .fi
213 .RE
214 .PP
215 First,
216 .B mhbuild
217 will look for an entry of the form:
218 .PP
219 .RS 5
220 mhbuild-compose-<type>/<subtype>
221 .RE
222 .PP
223 to determine the command to use to compose the content. If this isn't
224 found,
225 .B mhbuild
226 will look for an entry of the form:
227 .PP
228 .RS 5
229 mhbuild-compose-<type>
230 .RE
231 .PP
232 to determine the composition command. If this isn't found,
233 .B mhbuild
234 will complain.
235 .PP
236 An example entry might be:
237 .PP
238 .RS 5
239 mhbuild-compose-audio/basic: record | raw2audio -F
240 .RE
241 .PP
242 Because commands like these will vary, depending on the display
243 environment used for login, composition strings for different
244 contents should probably be put in the file specified by the
245 .B $MHBUILD
246 environment variable, instead of directly in your
247 user profile.
248 .PP
249 The \*(lqexternal-type\*(rq directives are used to provide a MIME
250 reference to a content, rather than enclosing the contents itself
251 (for instance, by specifying an ftp site). Hence, instead of
252 providing a filename as with the type directives, external-parameters
253 are supplied. These look like regular parameters, so they must be
254 separated accordingly. For example,
255 .PP
256 .RS 5
257 .nf
258 #@application/octet-stream; \\
259 type=tar; \\
260 conversions=compress \\
261 [this is the nmh distribution] \\
262 {attachment; filename="nmh.tar.gz"} \\
263 name="nmh.tar.gz"; \\
264 directory="/pub/nmh"; \\
265 site="ftp.math.gatech.edu"; \\
266 access-type=anon-ftp; \\
267 mode="image"
268 .fi
269 .RE
270 .PP
271 You must give a description string to separate the content parameters
272 from the external-parameters (although this string may be empty).
273 This description string is specified by enclosing it within
274 \*(lq[]\*(rq. A disposition string, to appear in a
275 \*(lqContent-Disposition\*(rq header, may appear in the optional
276 \*(lq{}\*(rq.
277 .PP
278 These parameters are of the form:
279 .PP
280 .RS 5
281 .nf
282 .ta \w'access-type= 'u
283 access-type= usually \fIanon-ftp\fR, \fImail-server\fR, or \fIurl\fR
284 name= filename
285 permission= read-only or read-write
286 site= hostname
287 directory= directoryname (optional)
288 mode= usually \fIascii\fR or \fIimage\fR (optional)
289 size= number of octets
290 server= mailbox
291 subject= subject to send
292 body= command to send for retrieval
293 url= URL of content
294 .fi
295 .RE
296 .PP
297 A mimimum \*(lqexternal\-type\*(rq directive for the
298 .B url
299 .I access\-type
300 would be as follows:
301 .PP
302 .RS 3
303 .nf
304 #@application/octet-stream [] access-type=url; \\
305 url="http://download.savannah.gnu.org/releases/nmh/nmh-1.5.tar.gz"
306 .fi
307 .RE
308 .PP
309 Any long URLs will be wrapped according to RFC 2231 rules.
310 .PP
311 The \*(lqmessage\*(rq directive (#forw) is used to specify a message or
312 group of messages to include. You may optionally specify the name of
313 the folder and which messages are to be forwarded. If a folder is not
314 given, it defaults to the current folder. Similarly, if a message is not
315 given, it defaults to the current message. Hence, the message directive
316 is similar to the
317 .B forw
318 command, except that the former uses
319 the MIME rules for encapsulation rather than those specified in RFC 934.
320 For example,
321 .PP
322 .RS 5
323 .nf
324 #forw +inbox 42 43 99
325 .fi
326 .RE
327 .PP
328 If you include a single message, it will be included directly as a content
329 of type \*(lqmessage/rfc822\*(rq. If you include more than one message,
330 then
331 .B mhbuild
332 will add a content of type \*(lqmultipart/digest\*(rq
333 and include each message as a subpart of this content.
334 .PP
335 If you are using this directive to include more than one message, you
336 may use the
337 .B \-rfc934mode
338 switch. This switch will indicate that
339 .B mhbuild
340 should attempt to utilize the MIME encapsulation rules
341 in such a way that the \*(lqmultipart/digest\*(rq that is created
342 is (mostly) compatible with the encapsulation specified in RFC 934.
343 If given, then RFC 934 compliant user-agents should be able to burst the
344 message on reception\0--\0providing that the messages being encapsulated
345 do not contain encapsulated messages themselves. The drawback of this
346 approach is that the encapsulations are generated by placing an extra
347 newline at the end of the body of each message.
348 .PP
349 The \*(lqbegin\*(rq directive is used to create a multipart content.
350 When using the \*(lqbegin\*(rq directive, you must specify at least one
351 content between the begin and end pairs.
352 .PP
353 .RS 5
354 .nf
355 #begin
356 This will be a multipart with only one part.
357 #end
358 .fi
359 .RE
360 .PP
361 If you use multiple directives in a composition draft,
362 .B mhbuild
363 will
364 automatically encapsulate them inside a multipart content. Therefore the
365 \*(lqbegin\*(rq directive is only necessary if you wish to use nested
366 multiparts, or create a multipart message containing only one part.
367 .PP
368 For all of these directives, the user may include a brief description
369 of the content between the \*(lq[\*(rq character and the \*(lq]\*(rq
370 character. This description will be copied into the
371 \*(lqContent-Description\*(rq header when the directive is processed.
372 .PP
373 .RS 5
374 .nf
375 #forw [important mail from Bob] +bob 1 2 3 4 5
376 .fi
377 .RE
378 .PP
379 Similarly, a disposition string may optionally be provided between
380 \*(lq{\*(rq and \*(lq}\*(rq characters; it will be copied into the
381 \*(lqContent-Disposition\*(rq header when the directive is processed.
382 If a disposition string is provided that does not contain a filename
383 parameter, and a filename is provided in the directive, it will be
384 added to the \*(lqContent-Disposition\*(rq header. For example, the
385 following directive:
386 .PP
387 .RS 5
388 .nf
389 #text/plain; charset=iso-8859-1 <>{attachment} /tmp/summary.txt
390 .fi
391 .RE
392 .PP
393 creates these message part headers:
394 .PP
395 .RS 5
396 .nf
397 Content-Type: text/plain; charset="iso-8859-1"
398 Content-Disposition: attachment; filename="summary.txt"
399 .fi
400 .RE
401 .PP
402 By default,
403 .B mhbuild
404 will generate a unique \*(lqContent-ID:\*(rq for each directive,
405 corresponding to each message part; however, the user may override
406 this by defining the ID using the \*(lq<\*(rq and \*(lq>\*(rq
407 characters. The
408 .B \-nocontentid
409 switch suppresses creation of all \*(lqContent-ID:\*(rq headers,
410 even in the top level of the message.
411 .PP
412 Normally
413 .B mhbuild
414 will choose an appropriate Content\-Transfer\-Encoding based on the content
415 and the MIME Content\-Type. However, you can override that in an
416 .B mhbuild
417 directive by specifying \*(lq*\*(rq and the encoding. Acceptable encoding
418 values are \*(lq8bit\*(rq, \*(lqqp\(*rq (for quoted\-printable), and
419 \*(lqb64\*(rq (for base64 encoding). It should be noted that undesired
420 results may occur if 8bit or quoted\-printable is selected for binary
421 content, due to the translation between Unix line endings and the line
422 endings use by the mail transport system.
423 .PP
424 In addition to the various directives, plaintext can be present.
425 Plaintext is gathered, until a directive is found or the draft is
426 exhausted, and this is made to form a text content. If the plaintext
427 must contain a \*(lq#\*(rq at the beginning of a line, simply double it,
428 e.g.,
429 .PP
430 .RS 5
431 ##when sent, this line will start with only one #
432 .RE
433 .PP
434 If you want to end the plaintext prior to a directive, e.g., to have two
435 plaintext contents adjacent, simply insert a line containing a single
436 \*(lq#\*(rq character, e.g.,
437 .PP
438 .RS 5
439 .nf
440 this is the first content
441 #
442 and this is the second
443 .fi
444 .RE
445 .PP
446 Finally, if the plaintext starts with a line of the form:
447 .PP
448 .RS 5
449 Content-Description: text
450 .RE
451 .PP
452 then this will be used to describe the plaintext content.
453 You MUST follow this line with a blank line before starting
454 your text.
455 .PP
456 By default, plaintext is captured as a text/plain content. You can
457 override this by starting the plaintext with \*(lq#<\*(rq followed by
458 a content-type specification. For example, e.g.,
459 .PP
460 .RS 5
461 .nf
462 #<text/enriched
463 this content will be tagged as text/enriched
464 #
465 and this content will be tagged as text/plain
466 #
467 #<application/x-patch [this is a patch]
468 and this content will be tagged as application/x-patch
469 .fi
470 .RE
471 .PP
472 Note that if you use the \*(lq#<\*(rq plaintext-form, then the
473 content-description must be on the same line which identifies the content
474 type of the plaintext.
475 .PP
476 When composing a text content, you may indicate the relevant character
477 set by adding the \*(lqcharset\*(rq parameter to the directive.
478 .PP
479 .RS 5
480 #<text/plain; charset=iso-8859-5
481 .RE
482 .PP
483 If a text content contains any 8\-bit characters (characters with the
484 high bit set) and the character set is not specified as above, then
485 .B mhbuild
486 will assume the character set is of the type given by the
487 standard
488 .IR locale (1)
489 environment variables. If these environment variables are not
490 set, then the character set will be labeled as \*(lqx-unknown\*(rq.
491 .PP
492 If a text content contains only 7\-bit characters and the character set
493 is not specified as above, then the character set will be labeled as
494 \*(lqus-ascii\*(rq.
495 .PP
496 By default text content with the high bit set is encoded with a 8bit
497 Content\-Transfer\-Encoding. If the text has lines longer than the value
498 of
499 .B \-maxunencoded
500 (which defaults to 78) then the text is encoded using the quoted\-printable
501 encoding.
502 .PP
503 The
504 .B \-headerencoding
505 switch will indicate which algorithm to use when encoding any message headers
506 that contain 8\-bit characters. The valid arguments are
507 .I base64
508 for based\-64 encoding and
509 .I quoted
510 for quoted\-printable encoding. The
511 .B \-autoheaderencoding
512 switch will instruct
513 .B mhbuild
514 to automatically pick the algorithm that results in a shorter encoded string.
515 .PP
516 Putting this all together,
517 here is an example of a more complicated message draft. The
518 following draft will expand into a multipart/mixed message
519 containing five parts:
520 .PP
521 .RS 5
522 .nf
523 To: nobody@nowhere.org
524 cc:
525 Subject: Look and listen to me!
526 --------
527 The first part will be text/plain
528 #<text/enriched
529 The second part will be text/enriched
530 #
531 This third part will be text/plain
532 #audio/basic [silly giggle] \\
533 |raw2audio -F < /usr/lib/sounds/giggle.au
534 #image/gif [photo of foobar] \\
535 /home/foobar/lib/picture.gif
536 .fi
537 .RE
538 .SS "Integrity Check"
539 If
540 .B mhbuild
541 is given the
542 .B \-check
543 switch, then it will also associate an integrity check with each
544 \*(lqleaf\*(rq content. This will add a Content-MD5 header field to
545 the content, along with the md5 sum of the unencoded contents, per RFC
546 1864. This may be used by the receiver of the message to verify that
547 the contents of the message were not changed in transport.
548 .SS "Transfer Encodings"
549 After
550 .B mhbuild
551 constructs the new MIME message by parsing directives,
552 including files, etc., it scans the contents of the message to determine
553 which transfer encoding to use. It will check for 8bit data, long lines,
554 spaces at the end of lines, and clashes with multipart boundaries. It will
555 then choose a transfer encoding appropriate for each content type.
556 .PP
557 If an integrity check is being associated with each content by using
558 the
559 .B \-check
560 switch, then
561 .B mhbuild
562 will encode each content with
563 a transfer encoding, even it the content contains only 7\-bit data. This
564 is to increase the likelihood that the content is not changed while in
565 transport.
566 .SS "Invoking mhbuild"
567 Typically,
568 .B mhbuild
569 is invoked by the
570 .B whatnow
571 program. This
572 command will expect the body of the draft to be formatted as an
573 .B mhbuild
574 composition file. Once you have composed this input file
575 using a command such as
576 .BR comp ,
577 .BR repl ,
578 or
579 .BR forw ,
580 you invoke
581 .B mhbuild
582 at the \*(lqWhat now\*(rq prompt with
583 .PP
584 .RS 5
585 What now? mime
586 .RE
587 .PP
588 prior to sending the draft. This will cause
589 .B whatnow
590 to execute
591 .B mhbuild
592 to translate the composition file into MIME format.
593 .PP
594 Normally it is an error to invoke
595 .B mhbuild
596 on file that already in MIME format. The
597 .B \-auto
598 switch will cause
599 .B mhbuild
600 to exit without error if the input file already has valid MIME headers.
601 The use of
602 .B \-auto
603 also enables the
604 .B \-nodirectives
605 switch.
606 .PP
607 Finally, you should consider adding this line to your profile:
608 .PP
609 .RS 5
610 lproc: show
611 .RE
612 .PP
613 This way, if you decide to
614 .B list
615 after invoking
616 .BR mime ,
617 the command
618 .PP
619 .RS 5
620 What now? list
621 .RE
622 .PP
623 will work as you expect.
624 .PP
625 The
626 .B \-dist
627 switch is intended to be used by
628 .BR dist .
629 It will cause mhbuild to not generate any MIME headers in the composition
630 file (such as \*(lqMIME-Version\*(rq or \*(lqContent-Type\*(rq), but it
631 will still encode message headers according to RFC 2047.
632 .SS "User Environment"
633 Because the environment in which
634 .B mhbuild
635 operates may vary for a
636 user,
637 .B mhbuild
638 will look for the environment variable
639 .BR $MHBUILD .
640 If present, this specifies the name of an additional user profile which
641 should be read. Hence, when a user logs in on a particular machine,
642 this environment variable should be set to refer to a file containing
643 definitions useful for that machine.
644 .PP
645 Finally,
646 .B mhbuild
647 will attempt to consult
648 .PP
649 .RS 5
650 %etcdir%/mhn.defaults
651 .RE
652 .PP
653 if it exists.
654 .PP
655 See "Profile Lookup" in
656 .IR mh-profile (5)
657 for the profile search order, and for how duplicate entries are treated.
658 .SS "Syntax of Composition Files"
659 The following is the formal syntax of a
660 .B mhbuild
661 \*(lqcomposition file\*(rq.
662 .PP
663 .RS 5
664 .nf
665 body ::= 1*(content | EOL)
666
667 content ::= directive | plaintext
668
669 directive ::= "#" type "/" subtype
670 0*(";" attribute "=" value)
671 [ "(" comment ")" ]
672 [ "<" id ">" ]
673 [ "[" description "]" ]
674 [ "{" disposition "}" ]
675 [ "*8bit" | "*qp" | "*b64" ]
676 [ filename ]
677 EOL
678
679 | "#@" type "/" subtype
680 0*(";" attribute "=" value)
681 [ "(" comment ")" ]
682 [ "<" id ">" ]
683 [ "[" description "]" ]
684 [ "{" disposition "}" ]
685 [ "*8bit" | "*qp" | "*b64" ]
686 external-parameters
687 EOL
688
689 | "#forw"
690 [ "<" id ">" ]
691 [ "[" description "]" ]
692 [ "{" disposition "}" ]
693 [ "+"folder ] [ 0*msg ]
694 EOL
695
696 | "#begin"
697 [ "<" id ">" ]
698 [ "[" description "]" ]
699 [ "{" disposition "}" ]
700 [ "alternative"
701 | "parallel"
702 | something-else ]
703 EOL
704 1*body
705 "#end" EOL
706
707 plaintext ::= [ "Content-Description:"
708 description EOL EOL ]
709 1*line
710 [ "#" EOL ]
711
712 | "#<" type "/" subtype
713 0*(";" attribute "=" value)
714 [ "(" comment ")" ]
715 [ "[" description "]" ]
716 [ "{" disposition "}" ]
717 [ "*8bit" | "*qp" | "*b64" ]
718 EOL
719 1*line
720 [ "#" EOL ]
721
722 line ::= "##" text EOL
723 -- interpreted as "#"text EOL
724 | text EOL
725 .fi
726 .RE
727 .SH FILES
728 .B mhbuild
729 looks for additional user profile files and mhn.defaults in multiple
730 locations: absolute pathnames are accessed directly, tilde expansion
731 is done on usernames, and files are searched for in the user's
732 .I Mail
733 directory as specified in their profile. If not found there, the directory
734 .RI \*(lq %etcdir% \*(rq
735 is checked.
736 .PP
737 .fc ^ ~
738 .nf
739 .ta \w'%etcdir%/ExtraBigFileName 'u
740 ^$HOME/\&.mh\(ruprofile~^The user profile
741 ^$MHBUILD~^Additional profile entries
742 ^%etcdir%/mhn.defaults~^System default MIME profile entries
743 .fi
744 .SH "PROFILE COMPONENTS"
745 .fc ^ ~
746 .nf
747 .ta 2.4i
748 .ta \w'ExtraBigProfileName 'u
749 ^Path:~^To determine the user's nmh directory
750 ^Current\-Folder:~^To find the default current folder
751 ^mhbuild-compose-<type>*~^Template for composing contents
752 .fi
753 .SH "SEE ALSO"
754 .IR mhlist (1),
755 .IR mhshow (1),
756 .IR mhstore (1)
757 .PP
758 .I "Proposed Standard for Message Encapsulation"
759 (RFC 934),
760 .PP
761 .I "The Content-MD5 Header Field"
762 (RFC 1864),
763 .PP
764 .I "Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies"
765 (RFC 2045),
766 .PP
767 .I "Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types"
768 (RFC 2046),
769 .PP
770 .I "Multipurpose Internet Mail Extensions (MIME) Part Three: Message Header Extensions for Non-ASCII Text"
771 (RFC 2047),
772 .PP
773 .I "Multipurpose Internet Mail Extensions (MIME) Part Four: Registration Procedures"
774 (RFC 2048),
775 .PP
776 .I "Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and Examples"
777 (RFC 2049),
778 .PP
779 .I "Definition of the URL MIME External-Body Access-Type"
780 (RFC 2017),
781 .PP
782 .I "MIME Parameter Value and Encoded Word Extensions: Character Sets, Languages, and Continuations"
783 (RFC 2231)
784 .SH DEFAULTS
785 .nf
786 .RB ` \-headers '
787 .RB ` \-realsize '
788 .RB ` \-norfc934mode '
789 .RB ` \-contentid '
790 .RB ` \-nocheck '
791 .RB ` \-noverbose '
792 .RB ` \-nodisposition '
793 .RB ` \-autoheaderencoding '
794 .RB ` "\-maxunencoded\ 78"'
795 .fi