1 .TH MHLIST %manext1% 2015-02-06 "%nmhversion%"
6 mhlist \- list information about nmh MIME messages
27 .RB [ \-headers " | " \-noheaders ]
28 .RB [ \-realsize " | " \-norealsize ]
29 .RB [ \-changecur " | " \-nochangecur ]
30 .RB [ \-verbose " | " \-noverbose ]
31 .RB [ \-disposition " | " \-nodisposition ]
36 command allows you to list information (a table of contents, essentially)
37 about the various parts of a collection of MIME (multi-media) messages.
40 manipulates MIME messages as specified in RFC 2045 to RFC 2049 (See
45 switch indicates that a one-line banner should be displayed above the
46 listing (the default).
52 to evaluate the \*(lqnative\*(rq (decoded) format of each content prior
53 to listing. This provides an accurate count at the expense of a small delay.
54 In either case, sizes will be expressed using SI prefix abbreviations
55 (K/M/G/T), which are based on factors of 1000.
59 switch is present, then the listing will show any \*(lqextra\*(rq
60 information that is present in the message, such as comments in the
61 \*(lqContent-Type\*(rq header.
65 switch is present, then the listing will show any relevant information from
66 the \*(lqContent-Disposition\*(rq header.
73 to use the specified file as the source message, rather than a message
74 from a folder. If you specify this file as \*(lq-\*(rq, then
76 will accept the source message on the standard input. Note that the
77 file, or input from standard input should be a validly formatted
78 message, just like any other
82 be in mail drop format (to convert a file in
83 mail drop format to a folder of
90 will list information about the entire message (all of its parts).
96 switches, you may limit and reorder the set of parts to be listed,
97 based on part number and/or content type.
99 A part specification consists of a series of numbers separated by
100 dots. For example, in a multipart content containing three parts,
101 these would be named as 1, 2, and 3, respectively. If part 2 was also
102 a multipart content containing two parts, these would be named as 2.1
103 and 2.2, respectively. Note that the
105 switch is effective only for messages containing a multipart content.
106 If a message has some other kind of content, or if the part is itself
107 another multipart content, the
109 switch will not prevent the content from being acted upon.
113 switch can also be used to restrict (or, when used in conjunction with
115 to further restrict) the selection of parts according to content type.
118 switches part will only select the first match from a multipart/alternative,
119 even if there is more than one subpart that matches (one of) the given
126 switches alone will cause either to select the part(s) they match.
127 Using them together will select only the part(s) matched by both
128 (sets of) switches. In other words, the result is the intersection,
129 and not the union, of their separate match results.
131 A content specification consists of a content type and a subtype.
132 The initial list of \*(lqstandard\*(rq content types and subtypes can
133 be found in RFC 2046.
135 A list of commonly used contents is briefly reproduced here:
139 .ta \w'application 'u
143 multipart mixed, alternative, digest, parallel
144 message rfc822, partial, external-body
145 application octet-stream, postscript
152 A legal MIME message must contain a subtype specification.
154 To specify a content, regardless of its subtype, just use the
155 name of the content, e.g., \*(lqaudio\*(rq. To specify a specific
156 subtype, separate the two with a slash, e.g., \*(lqaudio/basic\*(rq.
157 Note that regardless of the values given to the
159 switch, a multipart content (of any subtype listed above) is always
160 acted upon. Further note that if the
162 switch is used, and it is desirable to act on a message/external-body
165 switch must be used twice: once for message/external-body and once
166 for the content externally referenced.
168 By default, the parts of a multipart/alternative part are listed in
169 the reverse order of their placement in the message. The listing,
170 therefore, is in decreasing order of preference, as defined in RFC
173 switch can be used (one or more times, in order of ascending
174 preference) to let MH know which content types from a
175 multipart/alternative MIME part are preferred by the user, in order to
176 override the default preference order. Thus, when viewed by
178 the ordering of multipart/alternative parts will appear to change when
179 invoked with or without various
184 switch will cancel any previous
191 switches are functionally most important for
193 but are also implemented in
197 to make common part numbering possible across all three programs.
201 .ta \w'%nmhetcdir%/ExtraBigFileName 'u
202 ^$HOME/.mh_profile~^The user profile
204 .SH "PROFILE COMPONENTS"
208 .ta \w'ExtraBigProfileName 'u
209 ^Path:~^To determine the user's nmh directory
210 ^Current\-Folder:~^To find the default current folder
218 .RB ` +folder "' defaults to the current folder"
219 .RB ` msgs "' defaults to cur"
225 .RB ` \-nodisposition '
228 If a folder is given, it will become the current folder. The last
229 message selected will become the current message, unless the