- Support for SMTPUTF8 (RFC 6531) has been added. mhshow(1) already supported
RFC 6532, assuming all 8-bit message header field bodies are UTF-8 and use
of a UTF-8 locale.
+- mhfixmsg now replaces RFC 2047 encoding with RFC 2231 encoding of name and
+ filename parameters in Content-Type and Content-Disposition headers,
+ respectively.
-----------------
OBSOLETE FEATURES
scan(1), inc(1), and the other programs that rely on the format scanner.
- The first character of some very short (less than 4 characters) message
bodies is no longer dropped.
+- mhfixmsg now adds a Content-Transfer-Encoding header at the message level,
+ if needed after decoding text parts.
+- mhbuild now checks whether all text parts need a Content-Transfer-Encoding
+ header, not just those with a character set not specified.