X-Git-Url: https://diplodocus.org/git/nmh/blobdiff_plain/965fd1e75b90d6af932f3553efb591eddd29a6a3..fb6ea8dca0129dbb93ecb5fe1147a7b03138bbf8:/docs/pending-release-notes diff --git a/docs/pending-release-notes b/docs/pending-release-notes index fce0f5c4..ffcfcc9f 100644 --- a/docs/pending-release-notes +++ b/docs/pending-release-notes @@ -47,6 +47,14 @@ NEW FEATURES domain name in From: header line in message draft. - post(8) -snoop now attempts to decode base64-encoded SMTP traffic. - folder(1) -nocreate now prints a warning message for a non-existant folder. +- mhfixmsg(1) now allows -decodetext binary, though 8bit is still the default. +- inc(1) and msgchk(1) now support TLS encryption natively. +- Support for SMTPUTF8 (RFC 6531) has been added. mhshow(1) already supported + RFC 6532, assuming all 8-bit message header field bodies are UTF-8 and use + of a UTF-8 locale. +- mhfixmsg now replaces RFC 2047 encoding with RFC 2231 encoding of name and + filename parameters in Content-Type and Content-Disposition headers, + respectively. ----------------- OBSOLETE FEATURES @@ -79,3 +87,7 @@ BUG FIXES scan(1), inc(1), and the other programs that rely on the format scanner. - The first character of some very short (less than 4 characters) message bodies is no longer dropped. +- mhfixmsg now adds a Content-Transfer-Encoding header at the message level, + if needed after decoding text parts. +- mhbuild now checks whether all text parts need a Content-Transfer-Encoding + header, not just those with a character set not specified.