From: David Levine Date: Thu, 6 Oct 2016 13:39:27 +0000 (-0400) Subject: Merge branch 'welcome' X-Git-Url: https://diplodocus.org/git/nmh/commitdiff_plain/6fc2909634fb431c65ecfa8b6db4f6519f99b389?ds=inline Merge branch 'welcome' --- 6fc2909634fb431c65ecfa8b6db4f6519f99b389 diff --cc docs/pending-release-notes index bec2a5ae,74580e89..e5ae0899 --- a/docs/pending-release-notes +++ b/docs/pending-release-notes @@@ -52,12 -52,7 +52,13 @@@ NEW FEATURE - Support for SMTPUTF8 (RFC 6531) has been added. mhshow(1) already supported RFC 6532, assuming all 8-bit message header field bodies are UTF-8 and use of a UTF-8 locale. +- mhfixmsg now replaces RFC 2047 encoding with RFC 2231 encoding of name and + filename parameters in Content-Type and Content-Disposition headers, + respectively. +- If a message body contains 8-bit bytes, post(8) uses SMTP 8BITMIME if the + server supports it. If not, post fails with a message to the user to + encode the message for 7-bit transport. + - Added welcome message when nmh detects that its version changed. ----------------- OBSOLETE FEATURES