From afd7d2e640069ab1f2126478b365e6ff46db32d7 Mon Sep 17 00:00:00 2001 From: David Levine Date: Sat, 15 Oct 2016 09:58:24 -0400 Subject: [PATCH] Added to convertargs documentation. --- man/mhbuild.man | 13 +++++++++---- man/repl.man | 8 +++++--- 2 files changed, 14 insertions(+), 7 deletions(-) diff --git a/man/mhbuild.man b/man/mhbuild.man index b95c7948..a6193fd1 100644 --- a/man/mhbuild.man +++ b/man/mhbuild.man @@ -1,4 +1,4 @@ -.TH MHBUILD %manext1% "September 23, 2016" "%nmhversion%" +.TH MHBUILD %manext1% "October 15, 2016" "%nmhversion%" .\" .\" %nmhwarning% .\" @@ -194,6 +194,7 @@ entry, e.g., excludes parts of that .I TYPE from the draft. +.PP The .I mhn.defaults file @@ -204,7 +205,9 @@ and entries. Profile entries can be used to override corresponding .I mhn.defaults -entries, as usual. +entries, as usual. Text converters should limit text line lengths +to a maximum of 78 characters, and must limit them to a maximum of 998 +characters, per RFC 5322 Sec. 2.1.1. .PP For each .I TYPE @@ -214,14 +217,13 @@ part in runs .I CONVERTER ARGSTRING on the content of the part. -.PP Each part in .I FILE that has no corresponding TYPE entry in the profile or .I mhn.defaults is excluded from the draft; the user can include them using mhbuild -directives as usual. +directives. .PP .B repl inserts @@ -1051,6 +1053,9 @@ Template for composing contents. .I "Multipurpose Internet Mail Extensions (MIME) Part Three: Message Header Extensions for Non-ASCII Text" (RFC 2047) .PP +.I "Internet Message Format" +(RFC 5322) +.PP .I "MIME Parameter Value and Encoded Word Extensions: Character Sets, Languages, and Continuations" (RFC 2231) .PP diff --git a/man/repl.man b/man/repl.man index 4de6a70b..99df6d62 100644 --- a/man/repl.man +++ b/man/repl.man @@ -1,4 +1,4 @@ -.TH REPL %manext1% "December 14, 2014" "%nmhversion%" +.TH REPL %manext1% "October 15, 2016" "%nmhversion%" .\" .\" %nmhwarning% .\" @@ -251,9 +251,11 @@ must be non-empty while can be empty, e.g., '' in a shell command line. The .B \-convertargs switch can be used multiple times. +See the Convert Interface section of the +.B mhbuild +man page for description of the convert mechanism, and .I %docdir%/contrib/replaliases -shows the use of -.BR "repl \-convertargs" . +for examples of its use. .PP Although .B repl -- 2.56.0