1 Things to add to the release notes for the next full release:
7 - All nmh programs will now warn about multiple profile entries for
8 the same non-null, non-comment component. In previous versions, all
9 but the first were silently ignored.
10 - mhmail now supports all post(8) options, or optionally can use
11 send(1) with all of its options. Its formerly undocumented -resent
12 switch has been documented. And it has new -attach, -headerfield,
13 and -send/-nosend switches.
14 - Default to flock() locking on OpenBSD and Darwin.
15 - Added -directives support to mhbuild(1) to control whether or not
16 mhbuild will honor MIME directives by default. And added support
17 for special #on/#off/#pop directives to control the MIME directive
19 - Added -messageid switch to send(1) and post(8). This allows
20 selection of the style to use for generated Message-ID and
21 Content-ID header fields. The default localname style is
22 pid.time@localname, where time is in seconds, and matches previous
23 behavior. The random style replaces the localname with some
24 (pseudo)random bytes and uses microsecond-resolution time.
25 - Added -clobber switch to mhstore(1) to control overwriting of
27 - Added -outfile switch to mhstore(1).
28 - Added -noall/-all switches to sortm(1). sortm -noall requires
30 - $PAGER overrides the compiled-in default pager command.
31 - Added etc/scan.highlighted format file, as an example of how to
32 highlight/colorize the output of scan(1).
33 - inc(1) now supports a -port switch to specify the port used by the
35 - pick(1) now decodes MIME-encoded header fields before searching.
36 - The VISUAL and EDITOR environment variables are now supported as fallbacks
37 if the user does not configure an editor entry in their profile.
38 - The format engine (mh_format(5)) now properly accounts for multibyte
39 characters when accounting for column widths.
40 - burst(1) now can burst MIME-formatted digests (messages that contain
41 message/rfc822 parts instead of messages formatted with RFC 934).
42 - All proc entries (showproc, moreproc, etc) can now accept entries that
43 contain spaces and shell metacharacters. If found, such entries will
44 either be space-splitted or processed by /bin/sh.
45 - A new program, fmttest(1) is included to help debug format files
46 - mhshow/mhstore now have support for RFC-2017 (access-type=url) for
47 external message bodies.
48 - Added -retainsequences switch to refile(1).
49 - A new program, mhfixmsg(1), is included to rewrite MIME messages with
50 various transformations.
51 - Added -[no]rmmproc switches to rmm(1).
52 - Added support for Content-Disposition header (RFC 2183) to mhstore(1)
53 and mhn(1) when used with -auto.
54 - All nmh commands now support transactional locking for sequence files.
55 - There is no longer a per-folder maximum number of sequences.
56 - For the SMTP MTA TLS can now be negotiated at the beginning of the
57 connection with the -initialtls switch.
58 - Messages can now be selected using a relative offset from some other
59 message, or from the start or end of a sequence. See mh-sequences(5).
60 - The -changecur and -nochangecur switches have been added to mhlist(1).
61 - mhbuild(1) can now encode 8-bit message headers using RFC-2047 encoding
63 - The whatnow(1) attach feature will determine the content type of an
64 attachment using a program such as file --mime-type, if available at
65 configuration time. If not, it will use mhshow-suffix- entries as
66 before. The -v switch to attach causes it to display the mhbuild
67 directive that send(1) will use.
68 - mhbuild(1) now supports the -auto/-noauto flags (to be used by send(1)
69 when invoking mhbuild automatically).
70 - mhbuild(1) now is automatically run by send, to insure that all outgoing
71 messages have proper MIME formatting.
72 - A new header, "Attach", is supported by mhbuild; it is used to replace
73 previous functionality (which by default used a header named
79 - Changed exit status of each nmh command's -version and -help
81 - The following environment variables were deprecated in nmh 1.5
82 and removed from this release:
83 MHPOPDEBUG (use -snoop command line switch instead)
84 MM_NOASK (use -nolist and -nopause command line switches instead)
85 NOMHNPROC (use -nocheckmime command line switch instead)
86 FACEPROC (undocumented faceproc feature removed)
87 - Changed repl and dist default to -noatfile. The default of -atfile
88 was deprecated in nmh 1.5. If there are no requests to maintain
89 -atfile, it will be removed in the future.
90 - The undocumented -queue switch to mhmail has been removed.
91 - spost(8) has been merged into post(8). Its functionality is enabled
92 by selecting the sendmail/pipe mail transport method, described in
93 the mh-tailor(5) man page. The spost -noalias, -backup/-nobackup,
94 -push/-nopush, and -remove/-noremove switches are not supported by
95 post. Note that spost did not support -whom or Dcc, and neither
96 does post when using sendmail/pipe. And spost would expand blind
97 aliases and send them in the message; post with sendmail/pipe
98 refuses to do that. For backward compatibility, spost has been
99 replaced by a simple shell script that exec's post -mts
101 - Support for the undocumented and deprecated --enable-nmh-debug configure
102 flag has been removed.
103 - Support for encoding some characters designated as EBCDIC-unsafe
104 via the -ebcdicsafe and -noebcdicsafe switches to mhbuild has
106 - The configure flag --with-pager has been removed; the default pager
107 is now hardcoded as "more". Users are still free to override the
108 default using the PAGER environment variable or entries in .mh_profile.
109 - The configure flag --with-editor has been removed; the fallback editor
110 if none is configured is "vi".
111 - The support for the undocumented NOPUBLICSEQ preprocessor definition
112 to disable public sequence support has been removed.
113 - Support for the -normalize and -nonormalize switches to the ali(1) and
114 ap(8) commands has been removed.
115 - "make install" no longer strips executables. Use "make install-strip"
117 - The environment variable MM_CHARSET to indicate the native character
118 set is no longer supported. The native character set will be solely
119 determined by the locale settings.
120 - Temporary files are stored in the first non-null location of
121 {MHTMPDIR environment variable, TMPDIR environment variable, MH Path}.
122 They are no longer be stored in the location specified by the TMP
123 environment variable. As part of this change, suffixes were removed
124 from filenames of temporary files. This will break the use of display
125 applications that rely on the suffix to determine the file type.
130 - The undocumented -queue switch to post is deprecated/obsolete
131 and will be removed in the next release. It supports the
132 SMTP XQUE verb, which is obsolete according to
133 http://smtpfilter.sourceforge.net/esmtp.html
134 - conflict(8) is deprecated and will be removed from the next release.
135 - mhtest(8) is deprecated and will be removed from the next release.
136 - msh(1) is deprecated and will be removed from the next release.
137 - Support in alias files for the the "*" address-group is obsolescent
138 and will be removed in a future release.
144 - Replaced utilities that operate on pbm files with those that operate
145 on pnm files in etc/mhn.defaults [Bug #15152].
146 - Removed obsolete BUGS section at end of rcvstore(1) man page [Bug #4361].
147 - Fixed -nocc me doesn't account for Alternate-Mailboxes [Bug #36635].
148 - Propagate Mail-Followup-To [Bug #5571].
149 - "mark -sequence cur -delete all" now works for cur as well as any
150 other sequence, to allow clearing of the current message indication.
151 - The first alias contained in a blind list is now expanded. The
152 mh-alias(5) man page was updated to show that blind lists must not
153 be terminated with, or contain, a trailing semicolon [Bug #15604].
154 - Fixed sendfiles(1) to always provide a From: address. Also, updated
156 - Fixed pick(1) to properly unfold multiple-line header fields by
157 removing newlines instead of replacing them with spaces [Bug #15215].
158 - Removed the artificial limit of 1000 messages at a time for rmmproc.
159 - Fixed decoding of header fields when they contain a character that
161 - post(8) -sasl now honours username in .netrc [Bug #23168]. whom(1),
162 send(1), inc(1), and msgchk(1) also benefit from this fix. And, nmh
163 now supports specification of any valid filename in place of
165 - Added quoting of local part of invalid address in message being
166 replied to [Bug #26780].
167 - Fix segmentation fauls for %(putlit) and %(zputlit) format escapes when
168 the "str" register was NULL.