2 # NEWS - Release notes for nmh 1.7
5 Welcome to nmh, the new version of the classic MH mail handling system.
6 It's been over three years since the last release of nmh, and there have
7 been a number of significant changes since the last release. Long-time
8 MH and nmh uses should read careful the NOTEABLE CHANGES section, as there
9 are some significant changes to nmh behavior. Otherwise, please see the
10 README and INSTALL files for help on getting started with nmh.
16 The largest notable changes in the 1.7 release are:
18 - Complete unification of network security support. All network protocols
19 (currently, POP and SMTP) have been refactored to use a common set of
20 security routines. This means all protocols support all SASL mechanisms
21 (via the Cyrus-SASL library) and TLS. TLS support has been strengthened
22 to perform certificate name validation and to require TLS 1.1 as a
23 minimum protocol. Also, all protocols can make use of the OAuth2/XOAUTH
24 SASL mechanism, which is supported by gmail.
25 - send(1) now supports adding switches to post(8) based on the address or
26 domain of the email address in the From: header; this more easily allows
27 users to support multiple identities.
28 - A generic facility for passing arguments to filter programs in repl(1)
29 by use of the -convertargs switch.
30 - Native support for the manipulation of iCalendar requests; see mhical(1)
37 The following are new features for the 1.7 release of nmh:
39 - When building from source, configure will derive ${prefix} from an existing
40 nmh installation if it finds one in your $PATH.
41 - Added welcome message when nmh detects that its version changed.
42 - The default locations for configuration files and support binaries
43 have been changed. Configuration files now install into ${sysconfdir}/nmh,
44 and support binaries are placed in ${libexecdir}/nmh. If you are upgrading
45 an existing installation you should look for old configuration files in
46 ${sysconfdir} and merge any local customizations into the new files in
47 ${sysconfdir}/nmh, then remove the old files. ${libdir} will also contain
48 obsolete support programs that should be removed.
49 - All TLS connections now perform certificate validation (including hostname
50 matching) by default; can be disabled on a per-application basis.
51 - post now defaults to port 587 on 'smtp' message submission.
52 - A value of 0 for the width switch of scan(1), inc(1), ap(1), dp(1),
53 fmttest(1), and mhl(1) now means as many characters as the format
54 engine can produce [Bug #15274]. That amount is limited by internal
56 - If a component has trailing whitespace, e.g., body:component="> ",
57 mhl now trims that whitespace off when filtering blank text lines.
58 - An "rtrim" flag has been added to mhl to remove any trailing
59 whitespace from filtered text lines. A corresponding "nortrim" flag
61 - Added getmymbox and getmyaddr mh-format(5) function escapes.
62 - New -[no]changecur, -fixtype, -decodetypes, and -[no]crlflinebreaks switches
63 have been added to mhfixmsg(1).
64 - mhfixmsg now removes an extraneous trailing semicolon from header
66 - Added -convertargs switch to repl(1), to pass arguments to programs
67 specified in the user's profile or mhn.defaults to convert message
69 - Added mhical(1), to display, reply to, and cancel iCalendar (RFC 5545)
71 - added multiply format function
72 - "mhparam bindir" prints the path to the directory containing the public
73 executables (${bindir}).
74 - new "-prefer" switch for mhshow (and mhlist and mhshow), to allow specifying
75 the preferred content types to show, if present in a multipart alternative.
76 - mh-format now has %(kilo) and %(kibi) functions, to allow printing
77 numbers as, for example, "10K", or "2.3Mi"
78 - Support for the -sendmail flag to send/post to change the sendmail
79 binary when using the sendmail/pipe MTS.
80 - Added support to send(1) to specify switches to post(1) based on address or
81 domain name in From: header line in message draft.
82 - post(8) -snoop now attempts to decode base64-encoded SMTP traffic.
83 - folder(1) -nocreate now prints a warning message for a non-existent folder.
84 - mhfixmsg(1) now allows -decodetext binary, though 8bit is still the default.
85 - inc(1) and msgchk(1) now support TLS encryption natively.
86 - All network protocols support the XOAUTH authentication mechanism.
87 - Support for SMTPUTF8 (RFC 6531) has been added. mhshow(1) already supported
88 RFC 6532, assuming all 8-bit message header field bodies are UTF-8 and use
90 - mhfixmsg now replaces RFC 2047 encoding with RFC 2231 encoding of name and
91 filename parameters in Content-Type and Content-Disposition headers,
93 - If a message body contains 8-bit bytes, post(8) uses SMTP 8BITMIME if the
94 server supports it. If not, post fails with a message to the user to
95 encode the message for 7-bit transport.
96 - Fewer lseek(2)s will be used when reading headers in the common case.
97 - Single-character headers can be reliably formatted, etc., instead of
98 apparently being missing.
99 - ./configure's --enable-debug has been removed; it did nothing.
100 - configure now defaults to enabling each of TLS and Cyrus SASL if the
101 necessary headers and libraries are found.
102 - Moved build_nmh to top-level directory.
103 - Better error reporting for connections to network services
109 - The format scanner no longer subtracts 1 from the width. This has the
110 effect of no longer counting the trailing newline in the output of
111 scan(1), inc(1), and the other programs that rely on the format scanner.
112 - The first character of some very short (less than 4 characters) message
113 bodies is no longer dropped.
114 - mhfixmsg now adds a Content-Transfer-Encoding header at the message level,
115 if needed after decoding text parts.
116 - mhbuild now checks whether all text parts need a Content-Transfer-Encoding
117 header, not just those with a character set not specified.
118 - mhbuild no longer parses lines that start with # as directives with
120 - repl now makes sure that any Fcc header in a replied-to message is not
121 copied into the outgoing draft by default, and that the -fcc switch
122 actually works in the absence of a Fcc header in the replied-to message.
123 - A Content-ID is generated for message/external-body entities as required
124 by RFC 2045, even if -nocontentid is supplied to mhbuild.
125 - post will now expand aliases on a "From" line when doing a BCC [Bug #51098].
126 - scan can now handle empty files without violating an assert [Bug #51693].
132 - Support for the MHPDEBUG environment variable is deprecated and will be
133 removed from a future nmh release. Instead, use the -debug switch to pick.
134 - With the move of support binaries from ${libdir} to ${libexecdir}/nmh, the
135 mostly undocumented 'libdir' mhparam(1) component has been replaced by a
136 new 'libexecdir' component. 'libdir' will be removed in a future release.
142 - The undocumented -queue switch to post was deprecated in nmh 1.6, and was
143 removed in this release.
144 - conflict(8) was deprecated in nmh 1.6, and was removed in this release.
145 - mhtest(8) was deprecated in nmh 1.6, and was removed in this release.
146 - msh(1) was deprecated in nmh 1.6, and was removed in this release.
147 - Support in alias files for the the "*" address-group (everyone) was
148 deprecated in nmh 1.6, and was removed in this release.
149 - Support for multiple hostnames in the "servers" entry of mts.conf has
151 - Support in alias files for expanding aliases based on group membership
152 (=) and primary group (+) has been removed.
154 As always, feedback is welcome.
158 nmh-workers@nongnu.org
160 ----------------------------------------------------------------------------
163 # NEWS - Release notes for nmh 1.6
166 Welcome to nmh, the new version of the classic MH mail handling system.
167 It's been nearly two years since the last release of nmh, and there have
168 been a number of significant changes since the last release. Long-time
169 MH and nmh uses should read careful the NOTEABLE CHANGES section, as there
170 are some significant changes to nmh behavior. Otherwise, please see the
171 README and INSTALL files for help on getting started with nmh.
177 The following are new features for the 1.6 release of nmh:
179 - All nmh programs will now warn about multiple profile entries for
180 the same non-null, non-comment component. In previous versions, all
181 but the first were silently ignored.
182 - mhmail now supports all post(8) options, or optionally can use
183 send(1) with all of its options. Its formerly undocumented -resent
184 switch has been documented. And it has new -attach, -headerfield,
185 and -send/-nosend switches.
186 - Default to flock() locking on OpenBSD and Darwin.
187 - Added -directives support to mhbuild(1) to control whether or not
188 mhbuild will honor MIME directives by default. And added support
189 for special #on/#off/#pop directives to control the MIME directive
191 - Added -messageid switch to send(1) and post(8). This allows
192 selection of the style to use for generated Message-ID and
193 Content-ID header fields. The default localname style is
194 pid.time@localname, where time is in seconds, and matches previous
195 behavior. The random style replaces the localname with some
196 (pseudo)random bytes and uses microsecond-resolution time.
197 - Added -clobber switch to mhstore(1) to control overwriting of
199 - Added -outfile switch to mhstore(1).
200 - Added -noall/-all switches to sortm(1). sortm -noall requires
202 - $PAGER overrides the compiled-in default pager command.
203 - Added etc/scan.highlighted format file, as an example of how to
204 highlight/colorize the output of scan(1).
205 - inc(1) now supports a -port switch to specify the port used by the
207 - pick(1) now decodes MIME-encoded header fields before searching.
208 - The VISUAL and EDITOR environment variables are now supported as fallbacks
209 if the user does not configure an editor entry in their profile.
210 - The format engine (mh_format(5)) now properly accounts for multibyte
211 characters when accounting for column widths.
212 - burst(1) now can burst MIME-formatted digests (messages that contain
213 message/rfc822 parts instead of messages formatted with RFC 934).
214 - All proc entries (showproc, moreproc, etc) can now accept entries that
215 contain spaces and shell metacharacters. If found, such entries will
216 either be space-split or processed by /bin/sh.
217 - A new program, fmttest(1) is included to help debug format files. See
218 NOTABLE CHANGES below.
219 - mhshow/mhstore now have support for RFC-2017 (access-type=url) for
220 external message bodies.
221 - Added -retainsequences switch to refile(1).
222 - A new program, mhfixmsg(1), is included to rewrite MIME messages with
223 various transformations. See NOTABLE CHANGES below.
224 - Added -[no]rmmproc switches to rmm(1).
225 - Added support for Content-Disposition header (RFC 2183) to mhstore(1)
226 and mhn(1) when used with -auto.
227 - All nmh commands now support transactional locking for sequence files.
228 See NOTABLE CHANGES below.
229 - There is no longer a per-folder maximum number of sequences.
230 - For the SMTP MTA TLS can now be negotiated at the beginning of the
231 connection with the -initialtls switch.
232 - Messages can now be selected using a relative offset from some other
233 message, or from the start or end of a sequence. See mh-sequence(5).
234 - The -changecur and -nochangecur switches have been added to mhlist(1).
235 - mhbuild(1) can now encode 8-bit message headers using RFC-2047 encoding
236 rules. See NOTABLE CHANGES below.
237 - The whatnow(1) attach feature will determine the content type of an
238 attachment using a program such as file --mime-type, if available at
239 configuration time. If not, it will use mhshow-suffix- entries as
240 before. The -v switch to attach causes it to display the mhbuild
241 directive that send(1) will use.
242 - mhbuild(1) now supports the -auto/-noauto flags (to be used by send(1)
243 when invoking mhbuild automatically).
244 - mhbuild(1) now is automatically run by send, to insure that all outgoing
245 messages have proper MIME formatting. See NOTABLE CHANGES below.
246 - A new header, "Attach", is supported by mhbuild; it is used to replace
247 previous functionality (which by default used a header named
248 Nmh-Attachment). See NOTABLE CHANGES below.
249 - The default Content-Transfer-Encoding for text parts is now 8bit.
250 - mhbuild(1) now supports a selectable Content-Transfer-Encoding
251 - If nmh was configured with iconv(3) support, mhshow will convert, if
252 necessary, the charset of text/plain content to match the user's
253 locale setting. See NOTABLE CHANGES below.
254 - Added support for %{charset} display string escape to mhshow(1).
255 - The MIME parsing and generating routines now support RFC 2231 extended
256 parameter information.
257 - mh-mime(7) now provides an introduction to nmh's MIME handling.
258 - mhshow(1) will now by default display all text content under one pager,
259 and display markers for non-text and non-inline content. The content
260 markers are changeable via mh-format(5). See NOTABLE CHANGES below.
265 - Changed exit status of each nmh command's -version and -help
266 switches from 1 to 0.
267 - The following environment variables were deprecated in nmh 1.5
268 and removed from this release:
269 MHPOPDEBUG (use -snoop command line switch instead)
270 MM_NOASK (use -nolist and -nopause command line switches instead)
271 NOMHNPROC (use -nocheckmime command line switch instead)
272 FACEPROC (undocumented faceproc feature removed)
273 - Changed repl and dist default to -noatfile. The default of -atfile
274 was deprecated in nmh 1.5. If there are no requests to maintain
275 -atfile, it will be removed in the future.
276 - The undocumented -queue switch to mhmail has been removed.
277 - spost(8) has been merged into post(8). Its functionality is enabled
278 by selecting the sendmail/pipe mail transport method, described in
279 the mh-tailor(5) man page. The spost -noalias, -backup/-nobackup,
280 -push/-nopush, and -remove/-noremove switches are not supported by
281 post. Note that spost did not support -whom or Dcc, and neither
282 does post when using sendmail/pipe. And spost would expand blind
283 aliases and send them in the message; post with sendmail/pipe
284 refuses to do that. For backward compatibility, spost has been
285 replaced by a simple shell script that exec's post -mts
286 sendmail/pipe. See NOTABLE CHANGES below.
287 - Support for the undocumented and deprecated --enable-nmh-debug configure
288 flag has been removed.
289 - Support for encoding some characters designated as EBCDIC-unsafe
290 via the -ebcdicsafe and -noebcdicsafe switches to mhbuild has
292 - The configure flag --with-pager has been removed; the default pager
293 is now hardcoded as "more". Users are still free to override the
294 default using the PAGER environment variable or entries in .mh_profile.
295 - The configure flag --with-editor has been removed; the fallback editor
296 if none is configured is "vi".
297 - The support for the undocumented NOPUBLICSEQ preprocessor definition
298 to disable public sequence support has been removed.
299 - Support for the -normalize and -nonormalize switches to the ali(1) and
300 ap(8) commands has been removed.
301 - "make install" no longer strips executables. Use "make install-strip"
303 - The environment variable MM_CHARSET to indicate the native character
304 set is no longer supported. The native character set will be solely
305 determined by the locale settings.
306 - Temporary files are stored in the first non-null location of
307 {MHTMPDIR environment variable, TMPDIR environment variable, MH Path}.
308 They are no longer be stored in the location specified by the TMP
309 environment variable.
310 - Instead of printing PostScript attachments, by default, from mhshow,
311 try to find a suitable viewer.
312 - Support for parallel display of multipart/parallel content has been
313 removed from mhshow; all multipart content will be displayed in
315 - Support for -pause/-nopause switches on mhshow has been removed.
320 - The undocumented -queue switch to post is deprecated/obsolete
321 and will be removed in the next release. It supports the
322 SMTP XQUE verb, which is obsolete according to
323 http://smtpfilter.sourceforge.net/esmtp.html
324 - conflict(8) is deprecated and will be removed from the next release.
325 - mhtest(8) is deprecated and will be removed from the next release.
326 - msh(1) is deprecated and will be removed from the next release.
327 - Support in alias files for the the "*" address-group is obsolescent
328 and will be removed in a future release.
334 - Replaced utilities that operate on pbm files with those that operate
335 on pnm files in etc/mhn.defaults [Bug #15152].
336 - Removed obsolete BUGS section at end of rcvstore(1) man page [Bug #4361].
337 - Fixed -nocc me doesn't account for Alternate-Mailboxes [Bug #36635].
338 - Propagate Mail-Followup-To [Bug #5571].
339 - "mark -sequence cur -delete all" now works for cur as well as any
340 other sequence, to allow clearing of the current message indication.
341 - The first alias contained in a blind list is now expanded. The
342 mh-alias(5) man page was updated to show that blind lists must not
343 be terminated with, or contain, a trailing semicolon [Bug #15604].
344 - Fixed sendfiles(1) to always provide a From: address. Also, updated
346 - Fixed pick(1) to properly unfold multiple-line header fields by
347 removing newlines instead of replacing them with spaces [Bug #15215].
348 - Removed the artificial limit of 1000 messages at a time for rmmproc.
349 - Fixed decoding of header fields when they contain a character that
351 - post(8) -sasl now honours username in .netrc [Bug #23168]. whom(1),
352 send(1), inc(1), and msgchk(1) also benefit from this fix. And, nmh
353 now supports specification of any valid filename in place of
355 - Added quoting of local part of invalid address in message being
356 replied to [Bug #26780].
357 - Fix segmentation faults for %(putlit) and %(zputlit) format escapes when
358 the "str" register was NULL.
359 - Encode and decode text MIME types with canonical line breaks properly.
360 - mhstore(1) now obeys its -noverbose switch.
361 - Properly report the input filename when mhbuild encounters errors.
362 - Set the content-transfer-encoding properly when attaching message/rfc822
369 The biggest changes in this release are in the arena of MIME handling.
370 Specifically relating to MIME composition and display. On the
371 composition front, mhbuild(1) will now automatically be run by send(1)
372 for all drafts. Specifically, mhbuild is now run with the new -auto
373 flag, which will suppress the processing of mhbuild directives and cause
374 mhbuild to silently exit if the draft is already MIME-formatted. When
375 invoking mhbuild manually via the "mime" command at the WhatNow? prompt,
376 mhbuild will behave as before and process mhbuild directives.
378 In both cases (automatic and manual invocation) mhbuild will encode email
379 headers according to RFC-2047 rules. Mhbuild also will use RFC 2231
380 encoding rules for MIME parameters when appropriate. In addition, the
381 attach system has been substantially reworked; the new header name is
382 now "Attach" (to better align with other MUA behavior) and cannot be
383 changed by the end-user. The existing "attach" command simply adds
384 the filename(s) to the draft in new Attach: headers, and the actual
385 file processing is done by mhbuild; this attachment processing will
386 take place in either automatic or manual mode.
388 On the display front, mhshow(1) will now automatically convert text
389 into the user's native character set using iconv, if nmh was built
390 with iconv support. Also, mhshow will now by default only display
391 text content that was not marked as an attachment. By default all
392 displayed content wll be run under one pager, as opposed to individual
393 pagers for each part as was in the past. Non-displayed parts will be
394 indicated using a marker string, which can be customized by a new
397 All nmh utilities now understand RFC 2231-encoded MIME parameters and
398 will automatically convert the encoded parameters into the native
399 character set, when appropriate (again, assuming nmh was built with
402 In other changes, sequence files are now locked using transactional
403 locks: locks that are held across sequence file reading, modification,
404 and writing. The locking algorithm used for spool files and nmh data
405 files is now runtime configurable.
407 For people that struggle with mh-format(5) files, a new utility for testing
408 them has been developed: fmttest(1). It includes the ability to trace the
409 execution of format instructions.
411 For users that wish to use Unix utilities on their mail, a new utility
412 to transform MIME messages to more easily-digestable format is now
413 available: mhfixmsg(1). It supports a number of options to control
414 the message transformation.
416 For users of spost(8), the support for spost has been rolled into post(8)
417 under a new sendmail/pipe MTS. A shell script emulating the old behavior
418 of spost has been provided.
420 As always, feedback is welcome.
424 nmh-workers@nongnu.org
426 ----------------------------------------------------------------------------
429 # NEWS - Release notes for nmh 1.5
432 Welcome to nmh, the new version of the classic MH mail handling
433 system. Long-time MH and nmh users should read carefully the NOTABLE
434 CHANGES section, as there are some subtle but significant changes
435 to the way nmh now behaves. Otherwise, please see the README and INSTALL
436 files for help on getting started with nmh.
442 The following are new features for the 1.5 release of nmh.
444 - Improved performance for TLS encryption of the SMTP protocol.
445 - MH-E and POP support are now always compiled in.
446 - The selection of a locking directory for dot-locking files is now
447 controllable via configure.
448 - fileproc and mhlproc mh-profile are now obeyed by send, rcvdist,
450 - New mh-format instructions have been implemented: %(putlit),
451 %(concataddr), %(myhost), %(myname), %(localmbox). See mh-format(5)
453 - Nmh's idea of the local mailbox is now configurable via a new profile
454 entry, Local-Mailbox. See mh-profile(5) for more details.
455 - comp, forw, and dist now process all component templates through
456 mh-format(5), and now all support new command line arguments -from,
457 -to, -cc, -fcc, and -subject.
458 - burst(1) now supports any valid message delimiter according to RFC 934.
459 - post(8) now requires a From: header in all drafts that it processes;
460 see NOTABLE CHANGES below for more details.
461 - post(8) can now explicitly control the SMTP envelope address either via
462 the Sender: header or the new Envelope-From: header.
463 - The -attach option is now the default for send (using the header
464 Nmh-Attachment) and -attachformat 1 is the default attachment type.
465 - repl and dist now support new switches -atfile and -noatfile to control
466 the creation of the ./@ link to the message being replied or
467 redistributed. The current default is -atfile.
468 - Support (if available) for readline editing and filename completion at
470 - Support for using an external command to filter the body of a message
471 through in mhl. See mhl(1) for more details, specifically, the
472 "format" keyword, the "formatproc" entry in mh-profile(5), and the
473 -fmtproc switch for mhl and repl.
474 - Preliminary support for improved MIME handling when replying to messages!
475 Yes, a long requested feature has a solution. A perl script
476 called replyfilter is available; it is designed to act as a mhl
477 external filter to process MIME messages in a more logical way.
478 It is available in $(srcdir)/docs/contrib/replyfilter or is
479 typically installed as $(prefix)/share/doc/nmh/contrib/replyfilter.
480 See the comments at the top of replyfilter for usage information;
481 it will likely require some adjustment for your site. replyfilter
482 requires the MIME-Tools and MailTools perl modules.
484 ----------------------------
485 OBSOLETE/DEPRECATED FEATURES
486 ----------------------------
488 The following features have either been removed completely or marked
489 as officially deprecated for removal in a future release of nmh.
491 - The creation of the ./@ link to the message being replied or
492 redistributed is deprecated; -noatfile will be the default in the
493 next release. If there are no requests to maintain -atfile it
494 will be removed in a future release.
495 - Old code enabled by the UCI preprocessor definition has been removed.
496 - All configuration options that were formerly only adjustable by editing
497 config.h have either been moved into configure or removed completely.
498 - Support for the built-in ftp client (used when dealing with external-body
499 message parts in MIME messages) has been removed.
500 - The following environment variables are marked as obsolete/deprecated.
501 Support for them will be removed from the next nmh release:
502 MHPOPDEBUG (use -snoop command line switch instead)
503 MM_NOASK (use -nolist and -nopause command line switches instead)
504 NOMHNPROC (use -nocheckmime command line switch instead)
505 FACEPROC (undocumented faceproc feature to be removed)
506 - The hostable option of mts.conf is no longer needed and has been removed.
512 The largest change is that post(8) now requires a From: header in all drafts
515 The impetus for this change has been the evolution of email and client
516 systems. When MH was first developed the norm was to have tightly managed
517 clients that were part of the same domain as a user's email address. This
518 is no longer a valid assumption, and the algorithm used by nmh to determine
519 the user's local mailbox is no longer a reasonable default.
521 Unfortunately, the way that nmh uses the user's local mailbox used to happen
522 very late in the message process; it was handled by post during message
523 submission. If no From: header exists in the current draft post would
524 insert one based on it's idea of the local mailbox, which was frequently
527 After a long discussion within the nmh development community, it was
528 decided that the only reasonable way forward was to move the local mailbox
529 handling up a level and place it under more direct control of the end
530 user. post(8) no longer will try to determine the local mailbox name;
531 it will take that information from the draft message. Thus a From: header
532 is now required in all drafts.
534 As part of these changes, all message composition utilities now process
535 their component files using mh-format. All of the default component
536 files have been modified to include a From: header in them; this will
537 give the user a chance to see nmh's idea of the local mailbox and modify
538 it if desired. The new mh-profile(5) entry Local-Mailbox can be used
539 to adjust the local mailbox name if the system default is not appropriate.
541 So how should end-users adapt to these changes? Here are some suggestions:
543 1) If you use the default component files, everything should basically work
544 the same for you. You should see a From: header in the drafts of your
545 messages. If the address you see in the From: header is incorrect
546 you can change it via the Local-Mailbox profile entry. You can also
547 use the -from switch to change it on a per-command basis.
549 2) If you have custom component files that include a From: header or
550 you perform custom processing on drafts that end up placing a From:
551 header in the draft message, everything should work as before.
553 3) If you have custom component files that do NOT include a From: header
554 then you will have to adapt then to include a From: header. You
555 can either simply hard-code the correct From: header or use the
556 default component files as a guide (see mh-format(5) for more
557 details, specifically the %(localmbox) function).
559 The other significant change is the support for filters in mhl. Included
560 in the distribution is replyfilter, a filter designed for sane processing
561 of MIME messages during replies. Since this isn't as integrated into
562 nmh as we would prefer, it's included in the contrib directory as an
563 optional component. Please try it out and give us feedback.
567 nmh-workers@nongnu.org
569 ----------------------------------------------------------------------------
572 # NEWS - Release notes for nmh 1.4
575 This releases contains numerous bugfixes and a number of new features.
576 The new features include:
578 - SASL security layers (encryption) are now supported for the SMTP MTA.
579 - TLS is now supported for the SMTP MTA.
580 - inc can now incorporate mail from Maildir drops.
581 - You can now select the SMTP server and port from either "send" or a
582 user's mh_profile (you could always select the server; that option is
583 now documented). These are available via the -server and -port
585 - All networking code has been modified to use the new networking APIs
586 (getaddrinfo and friends). All networking code (with the exception of
587 the built-in ftp client) now supports IPv6.
588 - New commands 'new', 'fnext', 'fprev', and 'unseen' for showing folders
589 with unseen mail (or mail in any specified sequence), changing to next
590 such folder, changing to previous such folder, and scanning all such
591 folders, respectively. This is based on Luke Mewburn's 'new':
592 http://www.mewburn.net/luke/src/new
593 - nmh will no longer attempt to install a mhn.defaults file that causes
594 mhshow to open its own xterms.
596 A large chunk of old code has been garbage collected. Specifically,
597 support for APOP, RPOP, NNTP (including bboards) and MPOP is now gone.
598 Also gone is support for prefixing a \01 in the "servers" entry in
599 mts.conf to iterate over all servers on a named network.
601 ----------------------------------------------------------------------------
604 # NEWS - Release notes for nmh 1.3
607 It's been over two years since the 1.2 release; but the changes here are
608 mostly minor; largely bugfixes.
610 You should note that we have changed the default configuration to allow
611 all supported forms of address masquerading. For more details please see
612 the --enable-masquerade option to configure, and the mh-tailor and post