-/*
- * config.c -- master nmh configuration file
+/* config.c -- master nmh configuration file
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * addrsbr.h -- definitions for the address parsing system
+/* addrsbr.h -- definitions for the address parsing system
*/
#define UUCPHOST (-1)
-/*
- * aliasbr.h -- definitions for the aliasing system
+/* aliasbr.h -- definitions for the aliasing system
*
*/
-/*
- * crawl_folders.h -- crawl folder hierarchy
+/* crawl_folders.h -- crawl folder hierarchy
*/
#define CRAWL_NUMFOLDERS 100
-/*
- * dropsbr.h -- definitions for maildrop-style files
+/* dropsbr.h -- definitions for maildrop-style files
*/
/*
-/*
- * fmt_compile.h -- format types
+/* fmt_compile.h -- format types
*/
/* types that output text */
-/*
- * fmt_scan.h -- definitions for fmt_scan()
+/* fmt_scan.h -- definitions for fmt_scan()
*/
/*
-/*
- * icalendar.h -- data structures and common code for icalendar scanner,
+/* icalendar.h -- data structures and common code for icalendar scanner,
* parser, and application code
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
-/*
- * md5.h -- header file for md5 message digest
+/* md5.h -- header file for md5 message digest
* taken from RFC-1321/Appendices A.1/A.2
*/
-/*
- * mf.h -- include file for mailbox filters
+/* mf.h -- include file for mailbox filters
*/
#include <h/nmh.h>
-/*
- * mh.h -- main header file for all of nmh
+/* mh.h -- main header file for all of nmh
*/
#include <h/nmh.h>
-/*
- * mhcachesbr.h -- definitions for manipulating MIME content cache
+/* mhcachesbr.h -- definitions for manipulating MIME content cache
*/
/*
-/*
- * mhparse.h -- definitions for parsing/building of MIME content
+/* mhparse.h -- definitions for parsing/building of MIME content
* -- (mhparse.c/mhbuildsbr.c)
*/
-/*
- * mime.h -- definitions for MIME
+/* mime.h -- definitions for MIME
*/
#define VRSN_FIELD "MIME-Version"
-/*
- * mts.h -- definitions for the mail system
+/* mts.h -- definitions for the mail system
*/
/*
-/*
- * Network security library routines for nmh.
+/* Network security library routines for nmh.
*
* These are a common set of routines to handle network security for
* things like SASL and OpenSSL.
-/*
- * nmh.h -- system configuration header file
+/* nmh.h -- system configuration header file
*/
#ifdef HAVE_CONFIG_H
-/*
- * Implementation of OAuth 2.0 [1] for XOAUTH2 in SMTP [2] and POP3 [3].
+/* Implementation of OAuth 2.0 [1] for XOAUTH2 in SMTP [2] and POP3 [3].
*
* Google defined XOAUTH2 for SMTP, and that's what we use here. If other
* providers implement XOAUTH2 or some similar OAuth-based SMTP authentication
-/*
- * picksbr.h -- definitions for picksbr.c
+/* picksbr.h -- definitions for picksbr.c
*/
/*
-/*
- * popsbr.h -- header for POP client subroutines
+/* popsbr.h -- header for POP client subroutines
*/
/* TLS flags */
-/*
- * prototypes.h -- various prototypes
+/* prototypes.h -- various prototypes
*
* If you modify functions here, please document their current behavior
* as much as practical.
-/*
- * rcvmail.h -- rcvmail hook definitions
+/* rcvmail.h -- rcvmail hook definitions
*/
#include <ctype.h>
-/*
- * scansbr.h -- definitions for scan()
+/* scansbr.h -- definitions for scan()
*/
#define SCNENC 2 /* message just fine, but encrypted(!!) */
-/*
- * signals.h -- header file for nmh signal interface
+/* signals.h -- header file for nmh signal interface
*/
#ifdef HAVE_CONFIG_H
-/*
- * tws.h
+/* tws.h
*/
/* If the following is #defined, a timezone given as a numeric-only offset will
-/*
- * utils.h -- utility prototypes
+/* utils.h -- utility prototypes
*/
/* Call malloc(3), exiting on NULL return. */
-/*
- * smtp.c -- nmh SMTP interface
+/* smtp.c -- nmh SMTP interface
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * smtp.h -- definitions for the nmh SMTP Interface
+/* smtp.h -- definitions for the nmh SMTP Interface
*/
/* length is the length of the string in text[], which is also NUL
-/*
- * addrsbr.c -- parse addresses 822-style
+/* addrsbr.c -- parse addresses 822-style
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * ambigsw.c -- report an ambiguous switch
+/* ambigsw.c -- report an ambiguous switch
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * arglist.c -- Routines for handling argument lists for execvp() and friends
+/* arglist.c -- Routines for handling argument lists for execvp() and friends
*
* This code is Copyright (c) 2013, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * atooi.c -- octal version of atoi()
+/* atooi.c -- octal version of atoi()
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * base64.c -- routines for converting to base64
+/* base64.c -- routines for converting to base64
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * brkstring.c -- (destructively) split a string into
+/* brkstring.c -- (destructively) split a string into
* -- an array of substrings
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * charstring -- dynamically-sized char array that can report size
+/* charstring -- dynamically-sized char array that can report size
* in both characters and bytes
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
-/*
- * check_charset.c -- routines for character sets
+/* check_charset.c -- routines for character sets
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * client.c -- connect to a server
+/* client.c -- connect to a server
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * closefds.c -- close-up fd's
+/* closefds.c -- close-up fd's
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * concat.c -- concatenate a variable number (minimum of 1)
+/* concat.c -- concatenate a variable number (minimum of 1)
* of strings in managed memory
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * context_del.c -- delete an entry from the context/profile list
+/* context_del.c -- delete an entry from the context/profile list
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * context_find.c -- find an entry in the context/profile list
+/* context_find.c -- find an entry in the context/profile list
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * context_foil.c -- foil search of profile and context
+/* context_foil.c -- foil search of profile and context
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * context_read.c -- find and read profile and context files
+/* context_read.c -- find and read profile and context files
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * context_replace.c -- add/replace an entry in the context/profile list
+/* context_replace.c -- add/replace an entry in the context/profile list
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * context_save.c -- write out the updated context file
+/* context_save.c -- write out the updated context file
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * copyip.c -- copy a string array and return pointer to end
+/* copyip.c -- copy a string array and return pointer to end
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * cpydata.c -- copy all data from one fd to another
+/* cpydata.c -- copy all data from one fd to another
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * cpydgst.c -- copy from one fd to another in encapsulating mode
+/* cpydgst.c -- copy from one fd to another in encapsulating mode
* -- (do dashstuffing of input data).
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * crawl_folders.c -- crawl folder hierarchy
+/* crawl_folders.c -- crawl folder hierarchy
*
* This code is Copyright (c) 2008, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * This code is Copyright (c) 2013, by the authors of nmh. See the
+/* This code is Copyright (c) 2013, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
* complete copyright information.
*/
-/*
- * sbr/ctype-checked.c: checks char isn't used as the value for each of
+/* sbr/ctype-checked.c: checks char isn't used as the value for each of
* the ctype functions
*
* This code is Copyright (c) 2016, by the authors of nmh.
-/*
- * datetime.c -- functions for manipulating RFC 5545 date-time values
+/* datetime.c -- functions for manipulating RFC 5545 date-time values
*
* This code is Copyright (c) 2014, by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
-/*
- * discard.c -- discard output on a file pointer
+/* discard.c -- discard output on a file pointer
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * done.c -- terminate the program
+/* done.c -- terminate the program
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * dtime.c -- time/date routines
+/* dtime.c -- time/date routines
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * Routines to encode message headers using RFC 2047-encoding.
+/* Routines to encode message headers using RFC 2047-encoding.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * error.c -- main error handling routines
+/* error.c -- main error handling routines
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * escape_addresses.c -- Escape address components, hopefully per RFC 5322.
+/* escape_addresses.c -- Escape address components, hopefully per RFC 5322.
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fdcompare.c -- are two files identical?
+/* fdcompare.c -- are two files identical?
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmt_addr.c -- format an address field (from fmt_scan)
+/* fmt_addr.c -- format an address field (from fmt_scan)
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmt_compile.c -- "compile" format strings for fmt_scan
+/* fmt_compile.c -- "compile" format strings for fmt_scan
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmt_new.c -- read format file/string and normalize
+/* fmt_new.c -- read format file/string and normalize
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmt_rfc2047.c -- decode RFC-2047 header format
+/* fmt_rfc2047.c -- decode RFC-2047 header format
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmt_scan.c -- format string interpretation
+/* fmt_scan.c -- format string interpretation
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder_addmsg.c -- Link message into folder
+/* folder_addmsg.c -- Link message into folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder_delmsgs.c -- "remove" SELECTED messages from a folder
+/* folder_delmsgs.c -- "remove" SELECTED messages from a folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder_free.c -- free a folder/message structure
+/* folder_free.c -- free a folder/message structure
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder_pack.c -- pack (renumber) the messages in a folder
+/* folder_pack.c -- pack (renumber) the messages in a folder
* -- into a contiguous range from 1 to n.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * folder_read.c -- initialize folder structure and read folder
+/* folder_read.c -- initialize folder structure and read folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder_realloc.c -- realloc a folder/msgs structure
+/* folder_realloc.c -- realloc a folder/msgs structure
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * getarguments.c -- Get the argument vector ready to go.
+/* getarguments.c -- Get the argument vector ready to go.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * getcpy.c -- copy a string in managed memory
+/* getcpy.c -- copy a string in managed memory
*
* THIS IS OBSOLETE. NEED TO REPLACE ALL OCCURRENCES
* OF GETCPY WITH STRDUP. BUT THIS WILL REQUIRE
-/*
- * geteditor.c -- Determine the default editor to use
+/* geteditor.c -- Determine the default editor to use
*
* This code is Copyright (c) 2013, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * getfolder.c -- get the current or default folder
+/* getfolder.c -- get the current or default folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * getline.c -- replacement getline() implementation
+/* getline.c -- replacement getline() implementation
*
* This code is Copyright (c) 2016, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * Portions of this code are Copyright (c) 1988, 1993
+/* Portions of this code are Copyright (c) 1988, 1993
* The Regents of the University of California. All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
-/*
- * icalendar.l -- icalendar (RFC 5545) scanner
+/* icalendar.l -- icalendar (RFC 5545) scanner
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * icalparse.y -- icalendar (RFC 5545) parser
+/* icalparse.y -- icalendar (RFC 5545) parser
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * lock.c -- routines to lock/unlock files
+/* lock.c -- routines to lock/unlock files
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_atoi.c -- Parse a string representation of a message number, and
+/* m_atoi.c -- Parse a string representation of a message number, and
* -- return the numeric value of the message. If the string
* -- contains any non-digit characters, then return 0.
*
-/*
- * m_backup.c -- construct a backup file
+/* m_backup.c -- construct a backup file
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_convert.c -- parse a message range or sequence and set SELECTED
+/* m_convert.c -- parse a message range or sequence and set SELECTED
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_draft.c -- construct the name of a draft message
+/* m_draft.c -- construct the name of a draft message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_getfld.c -- read/parse a message
+/* m_getfld.c -- read/parse a message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_gmprot.c -- return the msg-protect value
+/* m_gmprot.c -- return the msg-protect value
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_maildir.c -- get the path for the mail directory
+/* m_maildir.c -- get the path for the mail directory
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_mktemp.c -- Construct a temporary file.
+/* m_mktemp.c -- Construct a temporary file.
*
* This code is Copyright (c) 2010, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_name.c -- return a message number as a string
+/* m_name.c -- return a message number as a string
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * m_popen.c -- Interface for a popen() call that redirects the current
+/* m_popen.c -- Interface for a popen() call that redirects the current
* process standard output to the popen()d process.
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
-/*
- * m_rand -- provides pseudorandom bytes
+/* m_rand -- provides pseudorandom bytes
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * makedir.c -- make a directory
+/* makedir.c -- make a directory
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * md5.c -- md5 message digest algorithm
+/* md5.c -- md5 message digest algorithm
* taken from RFC-1321/Appendix A.3
*/
-/*
- * message-id.c -- construct the body of a Message-ID or Content-ID
+/* message-id.c -- construct the body of a Message-ID or Content-ID
* header field
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
-/*
- * mf.c -- mail filter subroutines
+/* mf.c -- mail filter subroutines
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mime_type.c -- routine to determine the MIME Content-Type of a file
+/* mime_type.c -- routine to determine the MIME Content-Type of a file
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mts.c -- definitions for the mail transport system
+/* mts.c -- definitions for the mail transport system
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * netsec.c -- Network security routines for handling protocols that
+/* netsec.c -- Network security routines for handling protocols that
* require SASL and/or TLS.
*
* This code is Copyright (c) 2016, by the authors of nmh. See the
-/*
- * The Single Unix Specification function nl_langinfo(CODESET)
+/* The Single Unix Specification function nl_langinfo(CODESET)
* returns the name of the encoding used by the currently selected
* locale:
*
-/*
- * This code is Copyright (c) 2014, by the authors of nmh. See the
+/* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
* complete copyright information.
*/
-/*
- * This code is Copyright (c) 2014, by the authors of nmh. See the
+/* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
* complete copyright information.
*/
-/*
- * path.c -- return a pathname
+/* path.c -- return a pathname
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * pidstatus.c -- report child's status
+/* pidstatus.c -- report child's status
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * pidwait.c -- wait for child to exit
+/* pidwait.c -- wait for child to exit
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * print_help.c -- print a help message, and possibly the
+/* print_help.c -- print a help message, and possibly the
* -- profile/context entries for this command
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * print_sw.c -- print switches
+/* print_sw.c -- print switches
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * print_version.c -- print a version string
+/* print_version.c -- print a version string
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * push.c -- push a fork into the background
+/* push.c -- push a fork into the background
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * putenv.c -- (un)set an envariable
+/* putenv.c -- (un)set an envariable
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * r1bindex.c -- Given a string and a character, return a pointer
+/* r1bindex.c -- Given a string and a character, return a pointer
* -- to the right of the rightmost occurrence of the
* -- character. If the character doesn't occur, the
* -- pointer will be at the beginning of the string.
-/*
- * read_switch.c -- prompt the user for an answer from the list
+/* read_switch.c -- prompt the user for an answer from the list
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * read_switch_multiword.c -- get an answer from the user and return a string array
+/* read_switch_multiword.c -- get an answer from the user and return a string array
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * read_switch_multiword_via_readline.c -- get an answer from the user, with readline
+/* read_switch_multiword_via_readline.c -- get an answer from the user, with readline
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * read_yes_or_no_if_tty.c -- get a yes/no answer from the user
+/* read_yes_or_no_if_tty.c -- get a yes/no answer from the user
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * readconfig.c -- base routine to read nmh configuration files
+/* readconfig.c -- base routine to read nmh configuration files
* -- such as nmh profile, context file, or mhn.defaults.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * refile.c -- call the "fileproc" to refile the
+/* refile.c -- call the "fileproc" to refile the
* -- msg or draft into another folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * remdir.c -- remove a directory
+/* remdir.c -- remove a directory
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * Portions of this code are
+/* Portions of this code are
* Copyright (c) 1985 Regents of the University of California.
* All rights reserved.
*
-/*
- * seq_add.c -- add message(s) to a sequence
+/* seq_add.c -- add message(s) to a sequence
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_bits.c -- return the snprintb() string for a sequence
+/* seq_bits.c -- return the snprintb() string for a sequence
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_del.c -- delete message(s) from a sequence
+/* seq_del.c -- delete message(s) from a sequence
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_getnum.c -- find the index for a sequence
+/* seq_getnum.c -- find the index for a sequence
* -- return -1 if sequence doesn't exist
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * seq_list.c -- Get all messages in a sequence and return them
+/* seq_list.c -- Get all messages in a sequence and return them
* -- as a space separated list of message ranges.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * seq_nameok.c -- check if a sequence name is ok
+/* seq_nameok.c -- check if a sequence name is ok
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_print.c -- Routines to print sequence information.
+/* seq_print.c -- Routines to print sequence information.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_read.c -- read the .mh_sequence file and
+/* seq_read.c -- read the .mh_sequence file and
* -- initialize sequence information
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * seq_save.c -- 1) synchronize sequences
+/* seq_save.c -- 1) synchronize sequences
* -- 2) save public sequences
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * seq_setcur.c -- set the current message ("cur" sequence) for a folder
+/* seq_setcur.c -- set the current message ("cur" sequence) for a folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_setprev.c -- set the Previous-Sequence
+/* seq_setprev.c -- set the Previous-Sequence
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * seq_setunseen.c -- add/delete all messages which have the SELECT_UNSEEN
+/* seq_setunseen.c -- add/delete all messages which have the SELECT_UNSEEN
* -- bit set to/from the Unseen-Sequence
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * showfile.c -- invoke the `lproc' command
+/* showfile.c -- invoke the `lproc' command
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * signals.c -- general signals interface for nmh
+/* signals.c -- general signals interface for nmh
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * smatch.c -- match a switch (option)
+/* smatch.c -- match a switch (option)
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * snprintb.c -- snprintf a %b string
+/* snprintb.c -- snprintf a %b string
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * ssequal.c -- check if a string is a substring of another
+/* ssequal.c -- check if a string is a substring of another
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * strindex.c -- "unsigned" lexical index
+/* strindex.c -- "unsigned" lexical index
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * termsbr.c -- termcap support
+/* termsbr.c -- termcap support
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * trimcpy.c -- strip leading and trailing whitespace,
+/* trimcpy.c -- strip leading and trailing whitespace,
* -- replace internal whitespace with spaces,
* -- then return a copy.
*
-/*
- * unquote.c: Handle quote removal and quoted-pair strings on
+/* unquote.c: Handle quote removal and quoted-pair strings on
* RFC 2822-5322 atoms.
*
* This code is Copyright (c) 2013, by the authors of nmh. See the
-/*
- * uprf.c -- "unsigned" lexical prefix
+/* uprf.c -- "unsigned" lexical prefix
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * utils.c -- various utility routines
+/* utils.c -- various utility routines
*
* This code is Copyright (c) 2006, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * vector.c -- dynamically sized vectors
+/* vector.c -- dynamically sized vectors
*
* This code is Copyright (c) 2013, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * vfgets.c -- virtual fgets
+/* vfgets.c -- virtual fgets
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * ali.c -- list nmh mail aliases
+/* ali.c -- list nmh mail aliases
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * aliasbr.c -- new aliasing mechanism
+/* aliasbr.c -- new aliasing mechanism
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * anno.c -- annotate messages
+/* anno.c -- annotate messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * annosbr.c -- prepend annotation to messages
+/* annosbr.c -- prepend annotation to messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * ap.c -- parse addresses 822-style
+/* ap.c -- parse addresses 822-style
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * burst.c -- explode digests into individual messages
+/* burst.c -- explode digests into individual messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * comp.c -- compose a message
+/* comp.c -- compose a message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * dist.c -- re-distribute a message
+/* dist.c -- re-distribute a message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * distsbr.c -- routines to do additional "dist-style" processing
+/* distsbr.c -- routines to do additional "dist-style" processing
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * dp.c -- parse dates 822-style
+/* dp.c -- parse dates 822-style
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * dropsbr.c -- create/read/manipulate mail drops
+/* dropsbr.c -- create/read/manipulate mail drops
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * flist.c -- list nmh folders containing messages
+/* flist.c -- list nmh folders containing messages
* -- in a given sequence
*
* originally by
-/*
- * fmtdump.c -- compile format file and dump out instructions
+/* fmtdump.c -- compile format file and dump out instructions
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * fmttest.c -- A program to help test and debug format instructions
+/* fmttest.c -- A program to help test and debug format instructions
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * folder(s).c -- set/list the current message and/or folder
+/* folder(s).c -- set/list the current message and/or folder
* -- push/pop a folder onto/from the folder stack
* -- list the folder stack
*
-/*
- * forw.c -- forward a message, or group of messages.
+/* forw.c -- forward a message, or group of messages.
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * forwsbr.c -- subroutine to build a draft from a component file
+/* forwsbr.c -- subroutine to build a draft from a component file
*
* This code is Copyright (c) 2012, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * inc.c -- incorporate messages from a maildrop into a folder
+/* inc.c -- incorporate messages from a maildrop into a folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * install-mh.c -- initialize the nmh environment of a new user
+/* install-mh.c -- initialize the nmh environment of a new user
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mark.c -- add message(s) to sequences in given folder
+/* mark.c -- add message(s) to sequences in given folder
* -- delete messages (s) from sequences in given folder
* -- list sequences in given folder
*
-/*
- * mhbuild.c -- expand/translate MIME composition files
+/* mhbuild.c -- expand/translate MIME composition files
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhbuildsbr.c -- routines to expand/translate MIME composition files
+/* mhbuildsbr.c -- routines to expand/translate MIME composition files
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhcachesbr.c -- routines to manipulate the MIME content cache
+/* mhcachesbr.c -- routines to manipulate the MIME content cache
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhfixmsg.c -- rewrite a message with various transformations
+/* mhfixmsg.c -- rewrite a message with various transformations
*
* This code is Copyright (c) 2002 and 2013, by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
-/*
- * mhfree.c -- routines to free the data structures used to
+/* mhfree.c -- routines to free the data structures used to
* -- represent MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * mhical.c -- operate on an iCalendar request
+/* mhical.c -- operate on an iCalendar request
*
* This code is Copyright (c) 2014, by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
-/*
- * mhl.c -- the nmh message listing program
+/* mhl.c -- the nmh message listing program
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhlist.c -- list the contents of MIME messages
+/* mhlist.c -- list the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhlistsbr.c -- routines to list information about the
+/* mhlistsbr.c -- routines to list information about the
* -- contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * mhlogin.c -- login to external (OAuth) services
+/* mhlogin.c -- login to external (OAuth) services
*
* This code is Copyright (c) 2014, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhlsbr.c -- main routines for nmh message lister
+/* mhlsbr.c -- main routines for nmh message lister
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhparse.c -- misc routines to process MIME messages
+/* mhparse.c -- misc routines to process MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhn.c -- display, list, cache, or store the contents of MIME messages
+/* mhn.c -- display, list, cache, or store the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhoutsbr.c -- routines to output MIME messages
+/* mhoutsbr.c -- routines to output MIME messages
* -- given a Content structure
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * mhparam.c -- print mh_profile values
+/* mhparam.c -- print mh_profile values
*
* Originally contributed by
* Jeffrey C Honig <Jeffrey_C_Honig@cornell.edu>
-/*
- * mhparse.c -- routines to parse the contents of MIME messages
+/* mhparse.c -- routines to parse the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhpath.c -- print full pathnames of nmh messages and folders
+/* mhpath.c -- print full pathnames of nmh messages and folders
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhshow.c -- display the contents of MIME messages
+/* mhshow.c -- display the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhshowsbr.c -- routines to display the contents of MIME messages
+/* mhshowsbr.c -- routines to display the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhstore.c -- store the contents of MIME messages
+/* mhstore.c -- store the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mhstoresbr.c -- routines to save/store the contents of MIME messages
+/* mhstoresbr.c -- routines to save/store the contents of MIME messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * mkstemp.c -- create a temporary file
+/* mkstemp.c -- create a temporary file
*
* This code is Copyright (c) 2014 by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
-/*
- * msgchk.c -- check for mail
+/* msgchk.c -- check for mail
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * new.c -- as new, list all folders with unseen messages
+/* new.c -- as new, list all folders with unseen messages
* -- as fnext, move to next folder with unseen messages
* -- as fprev, move to previous folder with unseen messages
* -- as unseen, scan all unseen messages
-/*
- * packf.c -- pack a nmh folder into a file
+/* packf.c -- pack a nmh folder into a file
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * pick.c -- search for messages by content
+/* pick.c -- search for messages by content
*
* This code is Copyright (c) 2002, 2008, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * picksbr.c -- routines to help pick along...
+/* picksbr.c -- routines to help pick along...
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * popsbr.c -- POP client subroutines
+/* popsbr.c -- POP client subroutines
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * post.c -- enter messages into the mail transport system
+/* post.c -- enter messages into the mail transport system
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * prompter.c -- simple prompting editor front-end
+/* prompter.c -- simple prompting editor front-end
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rcvdist.c -- asynchronously redistribute messages
+/* rcvdist.c -- asynchronously redistribute messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rcvpack.c -- append message to a file
+/* rcvpack.c -- append message to a file
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rcvstore.c -- asynchronously add mail to a folder
+/* rcvstore.c -- asynchronously add mail to a folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rcvtty.c -- a rcvmail program (a lot like rcvalert) handling IPC ttys
+/* rcvtty.c -- a rcvmail program (a lot like rcvalert) handling IPC ttys
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * refile.c -- move or link message(s) from a source folder
+/* refile.c -- move or link message(s) from a source folder
* -- into one or more destination folders
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
-/*
- * repl.c -- reply to a message
+/* repl.c -- reply to a message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * replsbr.c -- routines to help repl along...
+/* replsbr.c -- routines to help repl along...
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rmf.c -- remove a folder
+/* rmf.c -- remove a folder
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * rmm.c -- remove a message(s)
+/* rmm.c -- remove a message(s)
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * scan.c -- display a one-line "scan" listing of folder or messages
+/* scan.c -- display a one-line "scan" listing of folder or messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * scansbr.c -- routines to help scan along...
+/* scansbr.c -- routines to help scan along...
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * send.c -- send a composed message
+/* send.c -- send a composed message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * sendsbr.c -- routines to help WhatNow/Send along
+/* sendsbr.c -- routines to help WhatNow/Send along
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * show.c -- show/list messages
+/* show.c -- show/list messages
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * slocal.c -- asynchronously filter and deliver new mail
+/* slocal.c -- asynchronously filter and deliver new mail
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * sortm.c -- sort messages in a folder by date/time
+/* sortm.c -- sort messages in a folder by date/time
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * viamail.c -- send multiple files in a MIME message
+/* viamail.c -- send multiple files in a MIME message
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * whatnow.c -- the nmh `WhatNow' shell
+/* whatnow.c -- the nmh `WhatNow' shell
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * whatnowproc.c -- exec the "whatnowproc"
+/* whatnowproc.c -- exec the "whatnowproc"
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * whatnowsbr.c -- the WhatNow shell
+/* whatnowsbr.c -- the WhatNow shell
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for
-/*
- * whom.c -- report to whom a message would be sent
+/* whom.c -- report to whom a message would be sent
*
* This code is Copyright (c) 2002, by the authors of nmh. See the
* COPYRIGHT file in the root directory of the nmh distribution for