24 files changed:
message/rfc822 parts instead of messages formatted with RFC 934).
- All proc entries (showproc, moreproc, etc) can now accept entries that
contain spaces and shell metacharacters. If found, such entries will
message/rfc822 parts instead of messages formatted with RFC 934).
- All proc entries (showproc, moreproc, etc) can now accept entries that
contain spaces and shell metacharacters. If found, such entries will
- either be space-splitted or processed by /bin/sh.
+ either be space-split or processed by /bin/sh.
- A new program, fmttest(1) is included to help debug format files. See
NOTABLE CHANGES below.
- mhshow/mhstore now have support for RFC-2017 (access-type=url) for
- A new program, fmttest(1) is included to help debug format files. See
NOTABLE CHANGES below.
- mhshow/mhstore now have support for RFC-2017 (access-type=url) for
- mh-mime(7) now provides an introduction to nmh's MIME handling.
- mhshow(1) will now by default display all text content under one pager,
and display markers for non-text and non-inline content. The content
- mh-mime(7) now provides an introduction to nmh's MIME handling.
- mhshow(1) will now by default display all text content under one pager,
and display markers for non-text and non-inline content. The content
- markers are changeable via mh-format(5). See NOTABLE CHANGES bellow.
+ markers are changeable via mh-format(5). See NOTABLE CHANGES below.
-----------------
OBSOLETE FEATURES
-----------------
OBSOLETE FEATURES
indicated using a marker string, which can be customized by a new
mh-format(5) string.
indicated using a marker string, which can be customized by a new
mh-format(5) string.
-All nmh utilites now understand RFC 2231-encoded MIME parameters and
+All nmh utilities now understand RFC 2231-encoded MIME parameters and
will automatically convert the encoded parameters into the native
character set, when appropriate (again, assuming nmh was built with
iconv support).
will automatically convert the encoded parameters into the native
character set, when appropriate (again, assuming nmh was built with
iconv support).
-%; This file shows how to use function escapes to enable hilighting
+%; This file shows how to use function escapes to enable highlighting
%; sequences for terminals that have the appropriate entries in their
%; termcap/terminfo files. Also it goes into more detail on exactly
%; what each line does.
%; sequences for terminals that have the appropriate entries in their
%; termcap/terminfo files. Also it goes into more detail on exactly
%; what each line does.
%<(mymbox{from})%<{to}To:%14(unquote(decode(friendly{to})))%>%>\
%<(zero)%17(unquote(decode(friendly{from})))%> \
%;
%<(mymbox{from})%<{to}To:%14(unquote(decode(friendly{to})))%>%>\
%<(zero)%17(unquote(decode(friendly{from})))%> \
%;
-%; Print out the subject and any of th mesage body that will fit on the
+%; Print out the subject and any of the message body that will fit on the
%; rest of the line. After that, print the terminal reset code to reset
%; all of the attributes to the next line.
%;
%; rest of the line. After that, print the terminal reset code to reset
%; all of the attributes to the next line.
%;
/*
* This structure describes an "interesting" component. It holds
* the name & text from the component (if found) and one piece of
/*
* This structure describes an "interesting" component. It holds
* the name & text from the component (if found) and one piece of
- * auxilary info. The structure for a particular component is located
+ * auxiliary info. The structure for a particular component is located
* by (open) hashing the name and using it as an index into the ptr array
* "wantcomp". All format entries that reference a particular component
* point to its comp struct (so we only have to do component specific
* by (open) hashing the name and using it as an index into the ptr array
* "wantcomp". All format entries that reference a particular component
* point to its comp struct (so we only have to do component specific
* format engine.
* reset - If set to true, the format compiler will reset the
* component hash table. The component hash table contains
* format engine.
* reset - If set to true, the format compiler will reset the
* component hash table. The component hash table contains
- * all of the references to message components refered to in
+ * all of the references to message components referred to in
* the format instructions. If you have multiple format
* strings that you want to compile and operate on the
* same message, this should be set to false.
* the format instructions. If you have multiple format
* strings that you want to compile and operate on the
* same message, this should be set to false.
* component buffer is a newline, it will be separated
* from previous text by ",\n\t"; otherwise if the last
* character of the previous text is a newline it will
* component buffer is a newline, it will be separated
* from previous text by ",\n\t"; otherwise if the last
* character of the previous text is a newline it will
- * simply be seperated by a "\t". This unusual processing
+ * simply be separated by a "\t". This unusual processing
* is designed to handle the case where you have multiple
* headers with the same name (e.g.: multiple "cc:" headers,
* even though that isn't technically allowed in the RFCs).
* is designed to handle the case where you have multiple
* headers with the same name (e.g.: multiple "cc:" headers,
* even though that isn't technically allowed in the RFCs).
* general folder attributes
*/
#define READONLY (1<<0) /* No write access to folder */
* general folder attributes
*/
#define READONLY (1<<0) /* No write access to folder */
-#define SEQMOD (1<<1) /* folder's sequences modifed */
+#define SEQMOD (1<<1) /* folder's sequences modified */
#define ALLOW_NEW (1<<2) /* allow the "new" sequence */
#define OTHERS (1<<3) /* folder has other files */
#define MODIFIED (1<<4) /* msh in-core folder modified */
#define ALLOW_NEW (1<<2) /* allow the "new" sequence */
#define OTHERS (1<<3) /* folder has other files */
#define MODIFIED (1<<4) /* msh in-core folder modified */
* inlineonly - If true, only display MIME parts that are marked with
* a disposition of "inline" (includes parts that lack a
* Content-Disposition header).
* inlineonly - If true, only display MIME parts that are marked with
* a disposition of "inline" (includes parts that lack a
* Content-Disposition header).
- * markerform - The name of a file containg mh-format(5) code used to
+ * markerform - The name of a file containing mh-format(5) code used to
* display markers about non-displayed MIME parts.
*/
void show_all_messages(CT *cts, int concat, int textonly, int inlineonly);
* display markers about non-displayed MIME parts.
*/
void show_all_messages(CT *cts, int concat, int textonly, int inlineonly);
*/
static sasl_conn_t *conn = NULL; /* SASL connection state */
*/
static sasl_conn_t *conn = NULL; /* SASL connection state */
-static int sasl_complete = 0; /* Has authentication succeded? */
+static int sasl_complete = 0; /* Has authentication succeeded? */
static sasl_ssf_t sasl_ssf; /* Our security strength factor */
static int maxoutbuf; /* Maximum crypto output buffer */
static char *sasl_outbuffer; /* SASL output buffer for encryption */
static sasl_ssf_t sasl_ssf; /* Our security strength factor */
static int maxoutbuf; /* Maximum crypto output buffer */
static char *sasl_outbuffer; /* SASL output buffer for encryption */
#endif /* TLS_SUPPORT */
/*
#endif /* TLS_SUPPORT */
/*
- * Convenience functions to replace occurences of fputs() and fputc()
+ * Convenience functions to replace occurrences of fputs() and fputc()
- * The next three give the numeric value withing the field
+ * The next three give the numeric value within the field
*/
/* get the basic part right-shifted */
*/
/* get the basic part right-shifted */
*
* COMMENT is a comment string, which is printable ASCII characters except
* for '(', ')', and '\'. Uses same quoting rules as QSTRING. To make
*
* COMMENT is a comment string, which is printable ASCII characters except
* for '(', ')', and '\'. Uses same quoting rules as QSTRING. To make
- * the grammer slightly less conflict-happy, COMMENT must include any FWS
+ * the grammar slightly less conflict-happy, COMMENT must include any FWS
* in front or behind of it (simply have it eaten in the lexer).
*
* Everything else is a SPECIAL, which is returned directly. These are
* in front or behind of it (simply have it eaten in the lexer).
*
* Everything else is a SPECIAL, which is returned directly. These are
/*
* Making dot-atom work was a little confusing; I finally handled it by
/*
* Making dot-atom work was a little confusing; I finally handled it by
- * defining "dot_atom_text" as having two or more ATEXTs separted by
+ * defining "dot_atom_text" as having two or more ATEXTs separated by
* '.', and defining dot_atom as allowing a single atom.
*/
dot_atom:
* '.', and defining dot_atom as allowing a single atom.
*/
dot_atom:
If an explicit host is not present, then MH checks for a bang to indicate
an explicit UUCP-style address. If so, this is noted. If not, the host is
If an explicit host is not present, then MH checks for a bang to indicate
an explicit UUCP-style address. If so, this is noted. If not, the host is
- defaulted, typically to the local host. The lack of an explict host is
+ defaulted, typically to the local host. The lack of an explicit host is
also noted.
If an explicit 822-style host is present, then MH checks to see if it
also noted.
If an explicit 822-style host is present, then MH checks to see if it
- * Spaces, but no shell metacharacters; space-split into seperate
+ * Spaces, but no shell metacharacters; space-split into separate
register struct node *np;
/*
register struct node *np;
/*
- * If list is emtpy, allocate head of profile/context list.
+ * If list is empty, allocate head of profile/context list.
*/
if (!m_defs) {
m_defs = (struct node *) mh_xmalloc (sizeof(*np));
*/
if (!m_defs) {
m_defs = (struct node *) mh_xmalloc (sizeof(*np));
/*
* getcpy.c -- copy a string in managed memory
*
/*
* getcpy.c -- copy a string in managed memory
*
- * THIS IS OBSOLETE. NEED TO REPLACE ALL OCCURENCES
+ * THIS IS OBSOLETE. NEED TO REPLACE ALL OCCURRENCES
* OF GETCPY WITH STRDUP. BUT THIS WILL REQUIRE
* CHANGING PARTS OF THE CODE TO DEAL WITH NULL VALUES.
*
* OF GETCPY WITH STRDUP. BUT THIS WILL REQUIRE
* CHANGING PARTS OF THE CODE TO DEAL WITH NULL VALUES.
*
/* We don't use MAX_PASS here because the maximum password length on a remote
POP daemon will have nothing to do with the length on our OS. 256 is
/* We don't use MAX_PASS here because the maximum password length on a remote
POP daemon will have nothing to do with the length on our OS. 256 is
- arbitrary but hopefully big enough to accomodate everyone. */
+ arbitrary but hopefully big enough to accommodate everyone. */
#define MAX_PASSWORD_LEN 256
#ifndef TCSANOW
#define MAX_PASSWORD_LEN 256
#ifndef TCSANOW
be parsed as well. Unfortunately the speed issue finally caught up with
us since this routine is at the very heart of MH.
be parsed as well. Unfortunately the speed issue finally caught up with
us since this routine is at the very heart of MH.
- To speed things up considerably, the routine Eom() was made an auxilary
+ To speed things up considerably, the routine Eom() was made an auxiliary
function called by the macro eom(). Unless we are bursting a maildrop,
the eom() macro returns FALSE saying we aren't at the end of the
message.
function called by the macro eom(). Unless we are bursting a maildrop,
the eom() macro returns FALSE saying we aren't at the end of the
message.
* getadrx() implements a partial 822-style address parser. The parser
* is neither complete nor correct. It does however recognize nearly all
* of the 822 address syntax. In addition it handles the majority of the
* getadrx() implements a partial 822-style address parser. The parser
* is neither complete nor correct. It does however recognize nearly all
* of the 822 address syntax. In addition it handles the majority of the
- * 733 syntax as well. Most problems arise from trying to accomodate both.
+ * 733 syntax as well. Most problems arise from trying to accommodate both.
*
* In terms of 822, the route-specification in
*
*
* In terms of 822, the route-specification in
*
* Search for this sequence name to see if we've seen
* it already. If we've seen this sequence before,
* then clear the bit for this sequence from all the
* Search for this sequence name to see if we've seen
* it already. If we've seen this sequence before,
* then clear the bit for this sequence from all the
- * mesages in this folder.
+ * messages in this folder.
*/
for (i = 0; i < svector_size (mp->msgattrs); i++) {
if (!strcmp (svector_at (mp->msgattrs, i), name)) {
*/
for (i = 0; i < svector_size (mp->msgattrs); i++) {
if (!strcmp (svector_at (mp->msgattrs, i), name)) {
#### Optional arguments:
#### 'keep first' -- first file is removed unless this is present.
#### 'ignore space' -- spacing differences will not be considered
#### Optional arguments:
#### 'keep first' -- first file is removed unless this is present.
#### 'ignore space' -- spacing differences will not be considered
-#### signficant, emulating GNU diff -w. It is assumed that the
+#### significant, emulating GNU diff -w. It is assumed that the
#### first file has already been run through prepare_space.
#### ':' <test name> -- will print '<test name>' in the failure message,
#### to make it easier to tell which of multiple tests has failed.
#### first file has already been run through prepare_space.
#### ':' <test name> -- will print '<test name>' in the failure message,
#### to make it easier to tell which of multiple tests has failed.
# the class node. If there are many fields or methods and many nodes the
# graph may become too big to be useful. The UML_LIMIT_NUM_FIELDS
# threshold limits the number of items for each type to make the size more
# the class node. If there are many fields or methods and many nodes the
# graph may become too big to be useful. The UML_LIMIT_NUM_FIELDS
# threshold limits the number of items for each type to make the size more
-# managable. Set this to 0 for no limit. Note that the threshold may be
+# manageable. Set this to 0 for no limit. Note that the threshold may be
# exceeded by 50% before the limit is enforced.
UML_LIMIT_NUM_FIELDS = 10
# exceeded by 50% before the limit is enforced.
UML_LIMIT_NUM_FIELDS = 10
* option is specified, only the last path name component of each field
* body is output. The entire field body is output if the -text option
* is used; the contents of the -text argument are ignored. If the -list
* option is specified, only the last path name component of each field
* body is output. The entire field body is output if the -text option
* is used; the contents of the -text argument are ignored. If the -list
- * option is used in conjuction with the new -number option described
+ * option is used in conjunction with the new -number option described
* below, each line is numbered starting with 1. A tab separates the
* number from the field body.
*
* below, each line is numbered starting with 1. A tab separates the
* number from the field body.
*
/*
* Read in lines until we get to a message delimiter.
*
/*
* Read in lines until we get to a message delimiter.
*
- * Previously we checked to make sure the preceeding line and
+ * Previously we checked to make sure the preceding line and
* next line was a newline. That actually does not comply with
* RFC 934, so make sure we break on a message delimiter even
* if the previous character was NOT a newline.
* next line was a newline. That actually does not comply with
* RFC 934, so make sure we break on a message delimiter even
* if the previous character was NOT a newline.
- * Copy a mesage which is being burst out of a digest.
+ * Copy a message which is being burst out of a digest.
* It will remove any "dashstuffing" in the message.
*/
* It will remove any "dashstuffing" in the message.
*/
- * mhfixmsg.c -- rewrite a message with various tranformations
+ * mhfixmsg.c -- rewrite a message with various transformations
*
* This code is Copyright (c) 2002 and 2013, by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
*
* This code is Copyright (c) 2002 and 2013, by the authors of nmh.
* See the COPYRIGHT file in the root directory of the nmh
* The previous code here used to call m_getfld() using
* pointers to the underlying output stdio buffers to
* avoid the extra copy. Tests by Markus Schnalke show
* The previous code here used to call m_getfld() using
* pointers to the underlying output stdio buffers to
* avoid the extra copy. Tests by Markus Schnalke show
- * no noticable performance loss on larger mailboxes
+ * no noticeable performance loss on larger mailboxes
* if we incur an extra copy, and messing around with
* internal stdio buffers is becoming more and more
* unportable as times go on. So from now on just deal
* if we incur an extra copy, and messing around with
* internal stdio buffers is becoming more and more
* unportable as times go on. So from now on just deal
* of message/partials. For the "Subject" header
* field, we also record it, so that a modified
* version of it, can be copied to the header
* of message/partials. For the "Subject" header
* field, we also record it, so that a modified
* version of it, can be copied to the header
- * of each messsage/partial in the collection.
+ * of each message/partial in the collection.
*/
if (!strcasecmp (name, "Subject")) {
size_t sublen;
*/
if (!strcasecmp (name, "Subject")) {
size_t sublen;
- * Return 1 if we already have a MIME-Verson header, 0 otherwise.
+ * Return 1 if we already have a MIME-Version header, 0 otherwise.